Annoying noise when I connect my headphones to the USB Hub

Hi,

I got a USB2-HUB10C2 at work. I am using a Macbook Pro (M1 microprocessor) computer . After I connect my headphones to the USB hub, a high frequency noise or buzzing starts. If I plug my headphones directly to one of my computer’s USB ports the noise disappears. I need to connect more USB devices so I need to use the USB hub.

I got this hub from my employer and I would like to know if there is anything I can do to remove the noise.

Thanks

Hi Erwin,

Thanks for reaching out to Plugable support! I’d be happy to help with that.

There are a few things we can take a look at, but the first thing I’d like to ask is what is the make and model of the headphones that you’re having trouble with?

Additionally, are you connecting these headphones to the two articulating USB ports or the other 8 static USB ports?

Hi RichardA,

Thank you for answering to my previous post. I am using Jabra’s Evolve2 40 and Plantronics’ Blackwire C3220. Both headsets generate the noise when I connect them to one of the 6 static USB ports of the Hub. Their specs don’t say if the cables are shielded.
I am having the same problem when I try to use the Hub on a computer running Windows 10.
It seems to me that the hub generates noise that gets amplified by my headphones.

I appreciate any help you can provide.

Thanks.

Thanks for the update.

This type of issue can sometimes be caused by certain system settings that create interference. Here are a few steps to try that will hopefully rectify the issue.

To work around this issue, set the power scheme to an non-adaptive mode:

  1. Click Start, click Control Panel, and then click Performance and Maintenance.
  2. Click Power Options.
  3. On the Power Schemes tab, click Always On in the Power schemes box, and then click OK

Hopefully this will help with the issue.

Richard A
Plugable Technologies
https://plugable.com/support

Thanks for the update.

This type of issue can sometimes be caused by certain system settings that create interference. Here are a few steps to try that will hopefully rectify the issue.

To work around this issue, set the power scheme to an non-adaptive mode:

  1. Click Start, click Control Panel, and then click Performance and Maintenance.
  2. Click Power Options.
  3. On the Power Schemes tab, click Always On in the Power schemes box, and then click OK

Hopefully this will help with the issue.

Hi, RichardA-

Thanks for the suggestion. I changed the settings on my computers and the noise is still there :frowning:

Erwin

Hi @efranz,

Thanks for giving that a shot. I’ll be jumping in here for Richard who is not available today.

I assume that you have some kind of docking station or USB-C hub in place so that you can connect the Plugable USB 2.0 hub to your M1 Mac. Can you clarify if your Plugable USB hub, USB-C hub/dock, and computer are all connected to the same power strip?

If different components of your setup are on different power outlets, a ground loop (hum) can be introduced. Keeping all of the components to one shared power source, such as a multi-outlet power strip or surge protector, can help reduce or eliminate the ground loop.

Please let me know if this might explain this!

Mitchell