Airplay does not work over Plugable USB Gigabit Ethernet on 10.6.8


#1

I purchased the widely recommended Plugable USB Gigabit Ethernet adapter (USB2-E1000) to substitute for an increasingly flaky onboard ethernet port on an aging core2duo macbook.

Having installed the drivers, and disabled IPv6, the adapter will connect to the LAN and I can access the internet and local file servers over the interface. However, Airplay will not see any clients or stream over that interface. If I re-enable my airport/wifi connection, then Airplay comes back to life and the clients are visible in iTunes (or Airfoil).

What’s the deal? How can I fix this?


#2

I’d note that this appears to be an issue with all mDNS/Bonjour traffic over the Plugable interface, as AFP dies when I switch to the wired LAN, but comes back to life when I re-activate the wifi.


#3

I solved this by assigning a static IP, removing the adapter (but leaving the configuration I had created), flushing the DNS cache, and then re-inserting the adapter. It then reconnected with the static IP and mDNS/Bonjour came back to life and so with it AFP and Airplay.


#4

Hi IT-

Thanks for posting with your issue. Can you please verify the serial number of the adapter you’re using?

Early production units (serial numbers starting with 5 or 6) of this model will work for Bonjour (Airplay, printer sharing, etc) with no driver installation.

On the more recent units, anything starting with a serial number of 7, 8, or 9 will do basic TCP/IP traffic only without the driver installed. For anything using Bonjour to work, the driver at the link below will need to be installed.

To summarize, as long as your adapter has a serial number beginning with a 7 or higher, I expect that installing the driver below will help:
http://s3.amazonaws.com/plugable/bin/…

Please let me know if you have any other questions, or especially if the driver installation doesn’t help.

Best wishes-

Jeff Everett
Plugable Technologies


#5

Thanks for the reply! The quickness is appreciated.

I imagine you were posting your response when I updated. I did indeed install the driver and reboot before I noticed Bonjour was dead started troubleshooting.

Regarding that initial install process – it may just be an issue with my particular submodel of macbook, or even with my router (a Buffalo) but after installing the OEM driver I had to manually disable IPv6 to get the adapter working even on the link layer. It appeared to be dead out of the box until I did that (although I could see the insertion/removal in Console).

Once I did disabled IPv6 I got a link light and had basic connectivity, but no mDNS etc until I did the steps described above. So…who knows.

It seems to be working now, I’m playing files on a NAS through iTunes to remote speakers without issue.

So the whole configure/remove/flush/insert dance might help other users with similarly old hardware and old, multiply upgraded installs with who knows what drivers, virtual interfaces and hidden processes preventing the dnscache from updating properly.


#6

And for reference, this unit is S/N 1089800002300109 on a macbook 2,1 running 10.6.8.


#7

Hi IT-

Thanks for confirming that what worked. It’s definitely unique (in most other cases we’ve found that just installing the driver works) but it’ great to know these steps in case anyone else hits a similar problem!

One quick question if I can: do you have IPv6 enabled on the Buffalo Router? I’m curious if there might be some issue specific to IPv6 networks that we should be aware of. If not, I’m guessing there was just something in system configs from the upgrades, etc you mentioned that was the cause.

Thanks again for confirming what worked in your case, this is an interesting one!

Best-

Jeff


#8

Hello. My problems have recurred.

The Buffalo (WHR-HP-G300N on stock firmware) has no options for IPv6 that I see, so my guess is that it simply doesn’t speak it and doesn’t want to hear it spoken on the LAN.

However, my Plugable adapter has stopped working again. I think I may have a bad unit. When I remove it and plug it in, the activity light comes on, but the link light stays off. And worryingly, the activity light stays on even if I disconnect the ethernet cable. This happens regardless of whether I plug directly into the computer, or into a hub (for testing).

Is this a known failure mode?


#9