Adapter seems to have installed in kde neon. How do I tell it to scan?

Upon being plugged into the usb port, it shows up as a bluetooth adapter in the System Setting. Under Bluetooth Devices there does not appear to be any Add options. Should I be looking somewhere else?

Hi John,

Thank you for posting. I haven’t had experience with KDE Neon, but since it seems to be built on an Ubuntu base, I assume it works similarly.

With the adapter plugged into the computer, could you please open a terminal, run the following command and tell me what it says?

sudo hciconfig


Plugable Support

hci0: Type: BR/EDR Bus: USB
BD Address: 5C:F3:70:84:8A:22 ACL MTU: 1021:8 SCO MTU: 64:1
RX bytes:918 acl:0 sco:0 events:43 errors:0
TX bytes:454 acl:0 sco:0 commands:43 errors:0

Thanks for responding David. I ran lsusb and it sees the Broadcom Bluetooth so I assumed it is loaded.

Hi John,

The results of the hciconfig command show it is loaded and functioning.

I don’t know what the Bluetooth interface looks like in KDE neon, so it is difficult to give exact instructions. Could you please tell me the make and model of the device you are trying to connect through the Plugable adapter, such a headphones, speaker, keyboard, etc?


Plugable Support

I am trying a Logitech MX Master mouse and a Microsoft Ergo Surface Keyboard.
The interface in neon is a window with 3 icons on the left: Devices, Adapters and Advanced Settings. Once I plugged in, an adapter appeared on the right when Adapters is selected. The Devices icon just shows ‘No devices found’. Here is where I expected an Add type option but there is none. The Advances Settings is simply a checkox to enable Bluetooth integration which is checked and a Receiving Files location.

I have tried this sequence which seemed to indicate the keyboard is connected but it does not work
jcp@jcp-neon:~$ bluetoothctl
[NEW] Controller 5C:F3:70:84:8A:22 jcp-neon [default]
[NEW] Device FA:D0:8F:CD:FF:93 Ergonomic Keyboard
[NEW] Device D9:DE:D3:D9:5A:93 MX Master
[bluetooth]# discoverable on
Changing discoverable on succeeded
[bluetooth]# pairable on
Changing pairable on succeeded
[bluetooth]# agent on
Agent registered
[bluetooth]# default-agent
Default agent request successful
[CHG] Device FA:D0:8F:CD:FF:93 Connected: no
[CHG] Device FA:D0:8F:CD:FF:93 Connected: yes
[CHG] Device D9:DE:D3:D9:5A:93 Connected: yes
[Ergonomic Keyboard]# paired-devices
Device FA:D0:8F:CD:FF:93 Ergonomic Keyboard
[Ergonomic Keyboard]# trust
Changing trust succeeded
[Ergonomic Keyboard]# trust FA:D0:8F:CD:FF:93
Changing FA:D0:8F:CD:FF:93 trust succeeded
[Ergonomic Keyboard]# connect FA:D0:8F:CD:FF:93
Attempting to connect to FA:D0:8F:CD:FF:93
Connection successful
[Ergonomic Keyboard]#

When I quit out and go back in, the devices are listed as NEW again. Does this help?

Hi John,

Both of the two devices you are trying to connect are Bluetooth Low Energy Devices, and they connect differently than classic Bluetooth devices. You may have to compile in the latest version of bluez to make it work. I’m answering this from home and won’t be at work until Wednesday due to the Christmas holiday, but when I do get in, I’ll see if I can write up a step-by-step procedure for connecting.

Just a work of warning though: We haven’t always found Bluetooth Low Energy connections to be reliable in Linux. If this turns out to be the case here, we will gladly refund the adapter price.

Plugable Support

Surprisingly both devices now show in the System Settings/Bluetooth/Devices. However neither work. Probably due to the Low Energy. Someone online said they did get the MS keyboard to work with Linux… Perhaps the recompile will do it.

Hi John,

Can you tell me which version of bluez you have? This command should do it:
sudo apt-cache policy bluez

Installed: 5.37-0ubuntu5
Candidate: 5.37-0ubuntu5.1
Version table:
5.37-0ubuntu5.1 500
500 xenial-updates/main amd64 Packages
500 xenial-security/main amd64 Packages
*** 5.37-0ubuntu5 500
500 xenial/main amd64 Packages
100 /var/lib/dpkg/status

Hi John,

I’m sorry for the delay in answering. It’s been very busy with all the people who bought Bluetooth adapters to connect the headphones they got for Christmas.

We recommend at least bluez version 5.43, but you might want to try the latest, which is 5.48.

Here are instructions for Ubuntu. Neon should be similar:

  1. Download and extract BlueZ 5.43 (or the latest version):

wget… && tar xf bluez-5.43.tar.xz

  1. Change to the BlueZ directory:

cd bluez-5.43

  1. Install the libraries necessary to successfully build and install BlueZ, as well as additional audio profile support:

sudo apt-get install pulseaudio-module-bluetooth libusb-dev libdbus-1-dev libglib2.0-dev libudev-dev libical-dev libreadline-dev

  1. Stop Bluetooth services:

sudo /etc/init.d/bluetooth stop

  1. Then in the BlueZ directory you should still be in; configure, make, and make install:

sudo ./configure && sudo make && sudo make install

  1. Once the install process is complete, restart the PC.

sudo reboot

  1. Try pairing and using your Bluetooth audio device again.

Please let me know if this helps or not.

Plugable Support

Thanks for the detailed response. I did the above with both 5.43 and 5.48 with an equal lack of success. What’s surprising is that for both after installing the
sudo apt-cache policy bluez
showed 5.37 only as the installed and candidate only.
I even tried sudo apt-get purge bluez which I saw on another thread. All that seemed to do was remove the bluetooth from the system setting GUI.
Is there a way to just remove 5.37 and replace it with .48 that I am missing?

Hi John,

Thank you for your message. Sorry about the delay in answering over the holidays.

Thank you for trying to update Bluez. I know it’s kind of a silly question, but I have to ask: Did you reboot Ubuntu after doing the update?


Plugable Support

Yes after each attempt using sudo reboot. I did not do a shutdown then restart as I would think the reboot was sufficient.