Acer alpha switch 12 and compatibility with USB 3.1type C dock?


#1

Acer today released the Alpha Switch 12 with USB 3.1 type C. I have one ordered and would like to know if the Plugable USB-C docks are compatible? Ready to give one a try if there are no issues.


#2

Hi Mark,

Thanks for posting, and I would be happy to answer your question. I have already responded to your direct inquiry via support@plugable.com, and repeat the contents below for the benefit of anyone else following this thread.

We do not have an Acer Switch Alpha 12 in our test lab, so at this time we can not guarantee compatibility with our USB-C docking stations. Each USB-C system is a little different, and the system manufacturer may have made changes that could prevent our docks from working properly. Hopefully that doesn’t sound too negative, but we like to set honest expectations up front to help prevent frustration done the road.

That said, if you did elect to try one of our USB-C docking stations and find it does not work as expected we do offer a 30-day no-hassle return policy.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

Hey Bob - thanks for your reply here. I never saw your reply to my direct inquiry - zapped by mail filters i betcha. I will give the Pluggble USB-C station a try. Might be a bit before I can but I will post bacck here once I do, Mentime, I’ll watcch for more from your side. And for sure I will give report once I have a go at it.


#4

You are very welcome Mark. Appreciate you taking the time to try out the unit and offering to report back. Just let us know the results as time allows.

Have a good day!

Bob


#5

Will do, thanks!


#6

Hi Mark,
I also have an Acer Switch Alpha 12 and was thinking of purchasing the dock. You mentioned that you were going to give it a try. Was it compatible?


#7

Hi All,

I did not see this until after I bought my Acer Switch Alpha 12 and Plugable USB-C triple display dock. The first few times I used the dock, it worked amazingly well. Charged the tablet, drove 2 monitors, USB peripherals, etc. Since then though, the Acer seems to have trouble recognizing the power source and it triggers power delivery on/off repeat"edly. I’ve tried resetting the dock, lowering power settings on the Acer for “on-plug” settings, etc. Really hoping I don’t have to return the dock because it’s a really nice product.

—EDIT—
Just saw another post on here about BIOS update possibly fixing the issue. Mine was still on ver. 1.01, ver 1.04 is latest. I will give that a try. To check BIOS, shutdown completely and hold Volume Up while pressing the power button.
https://www.acer.com/ac/en/US/content…

—EDIT 2—
So far, this seems to have addressed all of my issues. I will update again at the end of the week if it stays stable or not.


#8

Hi Corey,

Thanks for taking the time to share your experience, and very much appreciate the to the two follow-ups letting us know the BIOS update has helped. Please let us know if anything changes, and thanks again for sharing!

Bob


#9

As a follow up, the BIOS update did not completely fix my solution. I am seeing errors in my Windows Event Logs relating to the Ethernet Adapter in the dock, so, I am not sure if it is the tablet or a hardware issue in the dock. Continuing to investigate.


#10

Hi Corey,

Thanks for getting back with the update, appreciate very much the extra details. If the Ethernet adapter in the dock is not working properly, please send us an email at support@plugable.com along with one of our PlugDebug files -> http://plugable.com/support/plugdebug and your Amazon Order ID number (don’t post that here in the forum) and we will be happy to help.

Thank you!

Bob


#11