8 of the 10 ports are dead on my 10-Port USB 3.0 SuperSpeed Hub


#1

I have a Plugable 10-Port USB 3.0 SuperSpeed Hub. I recently lost power and when it came back on, the ports were dead. I though, ok, it got fried. But then I realized that the 2 flip up ports were still working. Are they configured differently? Could the other 8 have died but those 2 survived? Other than unplugging it and re plugging it in, is there any thing else I can try?


#2

Hi There,

Thank you so much for reaching out to us, I am sorry to hear that you have run into such a strange issue, but I would be more than happy to assist!

The two flip up ports on the dock do utilize a secondary controller chip inside of the hub, and are designated BC 1.2 charge ports, so they receive power differently then the other 8 ports on the hub. The power outage may have caused the internal hub chipsets to enumerate improperly, so resetting the internal chipsets may help resolve the issue. When you have a moment, please follow these instructions:

  1. Remove the Ac Adapter from the back of the hub, disconnect the USB 3.0 cable that connects the hub to your system, and remove all connected devices
  2. Wait 30 seconds
  3. After 30 seconds, please reconnect only the AC Adapter
  4. Wait 10 seconds
  5. After 10 seconds, please reconnect the USB cable from the hub to your system
  6. Reboot the system
  7. After the system has fully rebooted, see if the same behavior occurs, or if any devices connect when utilizing the USB ports.

If this has no effect, we may need to see if having a replacement unit sent out via warranty is possible.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Thanks so much for your response. No luck on the reset, but at least it now makes sense how the 2 flip up still work. It has served me well since 2014 so I’m well out of warranty but I appreciate your help
Thanks


#4

Hi There,

Thank you so much for working through those instructions, and getting back to us. I am sorry to hear that they did not resolve the issue!

If you are interested in viewing some of our newer hubs when looking for a replacement, please do not hesitate to reach out to us directly at support@plugable.com, and we would be more than happy to answer any questions you may have.

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support