7-port plugable hub not functioning with Dell Inspiron 530


#1

7-port plugable hub not functioning. Brand new hub connected to a working USB port freezes all USB connected devices. While hub is connected, no free USB ports work either. This occurs when the hub is in either a powered or non-powered state. The hub must be disconnect to allow the USB ports to work again. The 3 devices I am connecting with the hub are: a Dynex keyboard, an HP Deskjet 5440 printer, and a Logitech mouse adapter. My PC is a Dell Insipron 530. HELP !!!


#2

Hi Charles,

Thanks for posting here on our support forum, we’ll be able to help. What you are describing is very unusual. Please contact us at support@plugable.com with your Amazon Order Id, the serial number of the unit you have and a link to this thread and we’ll get you fixed up.

Thanks,
Jerome.

Plugable Technologies


#3

Jerome,

First of all, I am an advanced technical person. I have been in the Info Technology business for 25 years and have dealt with all kinds of software/hardware issues. Installation of this hub is as easy as it gets. I hooked up the power supply and received a ‘red’ light indicator providing me with info that the power supply was connnected properly. When I plugged in my 3 USB devices to the hub, I did see blue-colored lights indicating various ports were being used on the hub. For a 5-minute period of time, my 3 devices were working fine using the hub. Very strangely, after absolutely no interaction with the PC for 10 minutes while I temporarily left my PC work area, when I returned, the blue lights were off and my USB devices were not operating. I was alone in the household and there were no storms that would cause any power surges, etc. – thus, no person or natural event could have disrupted anything that I had installed. I also didn’t have any software tasks actively running in the background during any of this time.

Then, I started over with the install process, and although the red light turned on indicating power to the unit, any USB device plugged into the hub is not acknowldged by a corresponding blue light. This is particulary unusual since the initial set up of the hub worked fine, but it abruptly crashed, in the context of not recognizing USB devices attached to it. As Imentioned, the hub being connected to a power source, or not, makes no difference – the hub is not working AND it disables any ‘free’ USB ports because I tried plugging the hub into various USB ports and also tried plugging my keyboard into various USB ports, all of which were inoperable.


#4

for other who are interested:

We’ll be working with Charles to get his hub replaced.


#5