7 port hub not recognizing drives that are recognized with direct hookup


#1

E-mailed you last week asking whether your 7-hub powered USB port would work connecting non-powered compact hard drives. Specifically Toshiba 500 and 750 gb drives. Running of an older Dell running XP. Previously, when connected to a non-powered hub, a new Toshiba drive worked for awhile, but then ceased to function. Which could have been totally a drive problem non connected to the hub. I tried a Radio Shack powered hub and that would not recognize the drive. So returned it and quered you folks. Your respondent said your hub should work. Got one through Amazon and tried it yesterday. Again, the 500gb Toshiba is not recognized when I call see what drives are listed under “My computer”. In addition, a warning came up that said one folder of many music folders on the drive had been corrupted. I played a few bars from all the selections in the folder but they all see to be fine. Yet the question remains: why won’t the drives register through your powered hub?
Peter F


#2

Hi Richard,

Thanks for posting your experience here. I’m very sorry that your hard drives aren’t working with our hub the way we’d expect them to. Can you tell me some more details about the issue you’re seeing? First, can you say exactly which make and model of Toshiba external drives you have? Also, lets make sure the power connection is functioning ~ if you unplug the USB cable from the computer so the hub is just plugged in to the wall, does the red light stay on? Does a blue light come on when you plug the drive in? How about other devices? Can you verify that the hub works with other USB devices?

Thanks for your patience,
Jerome.

Plugable Technologies


#3

I’m having the exact same problem. Has anyone resolved this issue?


#4