4KHDMI flickering/rebooting graphics


#1

Plugable Model:UGA-4KHDMI Flickering and rebooting graphics to 4K TV. I have two 4K TV’s and the problem moves to whatever TV it is plugged into. Updated drivers and still happening.


#2

Hi there,

Thanks for posting.

A few quick questions to better understand what might be going on:

-May I have the brand/model info of the TVs being used?

-Which version of Windows is running on your system?

-If you set the resolution to a lower mode like 1080P, does the flickering still occur?

Thanks!
Gary


#3

They are (2) Seiki SE39UY04 LED TV
Windows 8.1
I’ll try the 1080p for awhile and see
Problem is very intermittent
This Plugable unit does rock though, especially ease of setup.


#4

Ah, the Seiki. Awesome display for the price, but it can be a bit finicky. (We have one here for testing.)

Couple suggestions:

  1. If you’re using the HDMI cables that came with the Seiki, they are notoriously twitchy. Trying a different brand-name HDMI cable definitely helped reduce hiccups on our Seiki.

  2. The firmware for 39" version is known to have some timing errors at 4K, which can lead to temporary signal loss. Seiki’s support team initially said they would fix the firmware in a future update, but they never actually moved forward with that. Instead, they started recommending that users with 4K issues install the firmware for the 50" version of the TV, which is more stable.

We’ve installed the 50" firmware on our test Seiki, and it did indeed help stabilize things substantially. We of course can’t be responsible if the update to the 50" firmware goes badly, but we’ve worked with many customers who’ve installed it and had good results. If you’re up for giving it a try, please let me know and I’ll see if I can track down a link to the firmware files.

Thanks,
Gary


#5

Closing thread due to inactivity. If you’d like to revisit the issue, please contact us directly via email at support@plugable.com.

Thanks!


#6