4K60 works with the DP-HDMI, but I can't get 4:4:4 color to my HDTV (HDMI 2.0 input)


#1

I have a RX560 with DP (1.4), HDMI and DVI. I am connecting to a TCL P605, which has HDMI2.0 turned on for the input and it’s set as ‘computer’ input. With HDMI out, I get 4K60, 4:4:4 fine. When I switch out to DP with the Plugable DP-HDMI (active, using the same HDMI cable), I can get 4K60, but only 4:2:0.

Running Linux with the open source AMD driver and it currently only supports 8bit color, so I’m sure that’s not the problem.

Is it possible that because the card supports DP 1.4 that the active DP-HDMI is trying for 1.4 levels of bandwidth negotiation?

Any ideas on what to check?

Edit: Machine info:
Qt: 5.10.0, KDE Frameworks: 5.43.0, Plasma: 5.12.1, Tumbleweed" v.“20180218”
4.5 (Core Profile) Mesa 18.0.0-rc3
Radeon RX 560 Series (POLARIS11 / DRM 3.23.0 / 4.16.0-rc2-mike, LLVM 5.0.1)


#2

Hi Michael,

Thanks for reaching out to us, I am sorry the output is not as desired.

I have taken a look at the specifications of the monitor and it has support for 120Hz, if the computer is trying to output 4K @ 120Hz it may be shifting the chroma sub-sampling down to 4:2:2 or 4:2:0. I would recommend setting the monitor for 60Hz to attempt to rule out the 120Hz setting causing this problem. The 120Hz option should be under the “Settings -> TV picture settings” menu on the television.

After changing this setting, please disconnect and reconnect the adapter, if this does not resolve the chroma sub-sampling issue, please restart the computer to make sure the settings are re-detected.

Please let me know if this helps,

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#3

I’m not seeing that in this case. 120Hz does not show up as a refresh rate option, either in Windows (with latest AMD Crimson) or Tumbleweed (latest AMDGPU open driver). In addition, the only options for settings on the HDMI input is HDMI 1.4 and HDMI 2.0. Of course, I’ve selected 2.0.

Here is what xrandr says about the display, fyi:

HDMI-A-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 800mm x 450mm
3840x2160 60.00*+ 59.94 30.00 24.00 29.97 23.98
4096x2160 60.00 59.94 30.00 24.00 29.97 23.98
1920x1200 60.00
1920x1080 60.00 60.00 59.94 30.00 24.00 29.97 23.98
1600x1200 60.00
1680x1050 59.88
1280x1024 75.02 60.02
1440x900 59.90
1280x960 60.00
1360x768 60.02
1280x800 59.91
.
.
.

I’ve plugged/unplugged, stopped/started, swapped cables, etc. in numerous combinations with no luck.

I did find out that the amdgpu driver will output 10bit if a monitor supports it (which most do), but that doesn’t explain it because, again, the HDMI 2.0 connection works perfectly for 4K60 4:4:4.

I can’t prove it but I think it has something to do with DP1.4 on the video card and the DP-HDMI active adapter. One thing I did notice is that it works for 4:4:4 if I set the refresh rate to 30Hz.

Perhaps the adapter is defaulting to 10bit behind my back?


#4

Hi Michael,

Sorry I was not entirely clear, the 120Hz setting is on the television within the settings menu, specifically the “TV Picture Settings” but can also be accessed when setting port specific settings ( however this is a universal setting so changing it for one port will change it for all ports ). If the television is advertising 120Hz, this may be causing graphics card to compress the signal for 120Hz even if it is only outputting 60Hz.

Please let me know if you are able to find and test this setting on the television.

You mentioned Windows, is the chroma sub-sampling set to 4:2:0 inside of Windows as well as GNU/Linux?

The Plugable DP-HDMI Active Adapter supports HDMI v2.0 which does not support 10bit color mode ( this was added to HDMI in the 2.0b specification ) and should only be communicating with the Radeon card with 8bit color mode. Please let me know if the DP-HDMI adapter is labeled as “rev b” on the back to make sure it is the latest model adapter.

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#5

This TV does not have that option under TV Picture Settings. It only has Brightness and Dolby Vision Notification – that’s it. In addition, under TV Inputs, it only has the name/icon and HDMI mode. Under HDMI mode, it has two options: 1.4 and 2.0.

The TV is 120CMI, which is *not* 120Hz refresh. The TV does not advertise 120Hz to linux or windows as an available refresh rate. If it was the case that it was advertising 120Hz somehow/somewhere behind the scenes, then why is the HDMI connection without the adapter giving me 4K60 4:4:4 just fine?

Yes, it is a “Rev B” unit.

Edit: BTW, I’m trying to run your debug tool, but I get a “permission denied at line 488” error. I’ll try it again later…


#6

Hi Michael,

Thanks for getting back to me. In Windows we can force 8bit color depth to see if this resolves the issue, the instructions are rather in depth so I can link the AMD support page here ( https://support.amd.com/en-us/kb-arti… ).

Please let me know if manually setting the color depth inside of the Radeon software within Windows resolves the chroma sub-sampling 4:2:2 issue within Windows. Unfortunately the available options may not exist within GNU/Linux to perform the same task without the ATI drivers.

Thank you,

Pat
Plugable Technologies
www.plugable.com/support


#7

Pat:
I just figured out how to verify 24b output (8bit/channel) on gnu/linux, so I’m going to test that again…then, I’ll try Windows later, as I have to dual-boot.

Yes, I am very familiar with the AMD settings app, changing bit depth, etc. I do know that on Windows, using just the HDMI-to-HDMI connection, 8bit was the only option available when I had RGB 4:4:4 selected in the AMD settings.

When I have a chance to continue debugging, I’ll post my results. BTW, I was able to get your debug tool working if that’s any use.


#8

Pat:
Okay, had a chance to get back to Windows. I’m on Windows 7 (Sp1, all the latest updates), AMD Crimson 18.2.2 (latest).

I have set the pixel format to RGB 4:4:4 and bitdepth to 8bit in Crimson (AMD Settings). 4K60 4:4:4 does *NOT* get passed. It looks like 4K60 4:2:2.

Then, I shutdown all, remove the hdmi cable from the DP-HDMI, plug into the HDMI port on the video card, reboot and I have perfect 4K60 4:4:4.

So, just like with gnu/linux, windows exhibits the same behavior: The DP-HDMI active adapter does *not* allow 4K60 4:4:4 in this scenario.

Again, the TCL TV is HDMI 2.0 and the DisplayPort output from the RX560 is 1.4, if this helps.


#9