4k stopped working

About a week ago, the extended display stopped working on 4k connector. I have updated everything to the latest versions, restarted, unplugged, etc… It has not changed. I had to change the extended monitor to the 2k port to have it work…

Help!

1 Like

Hello Ricardo,

Thanks for contacting Plugable support! I’m sorry to hear about this display issue through your Plugable dock , but I’d be happy to help!

The first step we’ll want to take is to make sure that the software used by the dock is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool.

To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel > Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool (https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe)
  4. Once the Cleaner has been run, reboot your computer (even if not prompted to)
  5. Download and install the 10.1 M2 DisplayLink software (https://plugable.s3.amazonaws.com/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows10.2+M2-EXE.exe)
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect the dock to your system

Please let me know if these steps help.

Thanks for giving us a chance to help!

Omar D.
Plugable Technologies

I just performed your instructions. Still no success. The 2k is still working, 4k → No

Hello Ricardo,

Thank you for reaching out with that update.

Could you provide me with the model number of your system?

This will allow me to look at specs as bit closer.

Thank you,

Omar D.
Plugable Technologies

ud-ultcdl d16-00012997

Hello Ricardo,

Thank you for reaching out with that update.

In this case, I’d like to request some logs from your computer to investigate further.

Could you please keep the Plugable dock connected to your system (with the non-working displays still attached), then navigate to our PlugDebug tool (https://plugable.com/support/plugdebug) and follow the instructions there?

Please email the file to support@Plugable.comwith the subject “Ticket #378803

Thanks for giving us a chance to help!

Omar D.
Plugable Technologies

sent info

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.