4 port hub killed mouse and keyboard


#1

Yesterday I purchased the 4 port hub for my HP laptop and used it to plug in my mouse and keyboard, which worked fine. This morning neither works. I removed the devices from the port and plugged directly into my laptop and they are still not working - any ideas?


#2

Update - the problem isn’t the mouse and keyboard, it’s the usb hubs on the side of the laptop that the Plugable hub was plugged into. I tried updating the driver which did not help. So now I’m afraid to even use this product!


#3

That’s very interesting! Soon after I installed my USB 3.0 docking station I lost my and added an external mouse and keyboard my laptop keyboard (which was working fine) stopped working and even if I disconnect from the USB 3.0 dock I can not get it to work again.


#4

Hello Jan (and Kevin),

Sorry to hear both of you have had problems with your Plugable products and devices not being properly detected.

The first thing I would recommend in Jan’s case would be to fully disconnect our hub and all other USB devices from your laptop and fully shut off the laptop. (Also if you can let me know which model USB hub you have, we sell a few)

Next turn the laptop back on, and test the USB ports on the laptop with a known good USB device. I would recommend against the keyboard and mouse since we’re not sure if they are working properly or not.

I would try another device like a flash drive, or a different keyboard or mouse if you have one, or verify the current mouse/keyboard works on another computer.

Let me know what you find and we can proceed from there. My next step will likely to be to request some diagnostics from the computer side to verify if the drivers are looking like a problem or not.

For Kevin, which USB 3.0 dock do you have? To troubleshoot and diagnose this issue, we may want to open a separate support thread for you.

Thanks,

Joshua Henry
Plugable Technologies


#5

Thanks Josh,
I have opened up another ticket.


#6

The mouse and keyboard do work on the ports on the other (right) side of the laptop - I had inserted the port into the . I did insert a flash drive into both ports on the left side, neither works. I have also restarted the laptop a couple of times but nothing has changed.


#7

Hello Jan,

(and thanks Kevin for opening a new ticket!)

Thanks for testing. So it sounds like none of the USB ports on the laptop are functioning.

Just to double check, you mention you restarted the laptop, but did you completely turn it off?

Another trick, if your laptop can have the battery unplugged, try pulling the battery and unplugging the charger cable and leave it off for about 15min.

If none of that works let me know and I think we’ll want to get some diagnostic information so I’ll contact you directly over email for that.

Best wishes.


#8

Since I have not heard back in several days I am going to close this thread. If you need further assistance please contact us directly at support@plugable.com


#9