3900 blue screen


#1

Any thoughts about why only certain USB ports seem to be compatible with this brand of laptop and this docking station?

I have TWO MSI GS72 Stealth laptops both using a Plugable UD-3900 dock.

For whatever reason, if I connect this dock (with NO other devices plugged into it) to the left side of the laptop USB 3.0 ports, the system will blue screen, then be stuck in a BSOD loop until reloading. You cant even enter safe mode.

Do you have any ideas on why this is? I’ve tested both laptops, both docks, both exhibit the same behavior, when you plug them in to the right side of the laptop, everything works as expected…left side…BSOD loop.

Both of these devices are less than a year old, and I’d love to return them for a “better / updated product” if this unit will continue to have these issues.

  • I’ve also tried both having the driver software from your site pre-installed before inserting the device, as well as letting windows detect it 100% and download/install what it wants
  • The end result is always the same
  • I’ve verified the MSi laptop has the latest bios update

#2

Hi Dan,

Thanks for posting! I see you have also reached out to us via support@plugable.com and I have already sent my direct reply. Please respond only to the direct reply so we can keep everything in one place.

For the benefit of anyone else following this thread, the best way forward after a bluescreen error is to send a PlugDebug file (http://plugable.com/support/plugdebug) to support@plugable.comThis will allow us to examine system log files to determine the next steps.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3