2TB NVMe SSD not recognized after intializing and formatting

Today I purchased your Plugable USB 3.1 GEN 2 NVMe SSD Enclosure for my new SAMSUNG 970 EVOPlus NVMe M.2 2TB V-NAND SSD (Model: MZ-V782T0, s/n: S59CNZFNA25867N).
My OS is Win10 Version 20H2 (OS Build 19042.630).
*Problem 1: Neither Enclosure paperwork nor YouTube initializing/formating video nor website addresses Enclosure cable plug polarity, if any.
Have I spooged my SSD by cabling the Enclosure incorrectly?
I should not have to be asking; it should be idiot proof.
But the cables unfortunately are not marked.
The cable tags read the same even tho the cables are not identical.
If cable polarity exists, it should be made clear somewhere if only on your website.
*Problem 2: Nowhere is the purpose of included one-sided sticky pads addressed.
Nevertheless, I tried following the video…
*Problem 3: Initialization/Formatting Video claims that SSD will be recognized by Windows Device Manager.
Not true. Popup dialogue box reads “The Semaphore Timeout Period Has Expired”. And see Attachment 1 - “The system cannot find the file specified.”.
Tried running SFM and disabling Malwarebytes antivirus and Windows Security.
*Problem 4: After initializing, popup dialogue box reads "USB device not recognized. " See Attachment 2.
*Problem 5: After formatting (see Attachment 3), Virtual Disk Manager popup dialogue box reads “USB device not recognized.
The last USB device you connected to this computer malfunctioned, and Windows does not recognize it.
” See Attachment 4.

	Your system is not allowing me to attach the PlugDebug zip file. :(

It also appears that the pngs are not uploading. :frowning:

	Thanks for any help. I'm sure you are busy. Best	John
	p.s. i hope the ambiguous enclosure cable plug has not rendered the $281.46 SSD. :(![1 - File not found |690x388](upload://624tiC3oYqPXKYdoUPO6kqISQOU.png) ![Device malfunctioned |690x388](upload://sllSiD1QEaJVmKluuWg4xMhWscj.png) ![3 - Formating Disc 2 |690x388](upload://vYW5sOQiD6Naviv233PE4EuVrA6.png) ![4 - USB device not recognized |690x388](upload://jzyw40O4lEJD6tjcvdZenluIoQJ.png)`![1 - File not found |690x388](upload://624tiC3oYqPXKYdoUPO6kqISQOU.png) `

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.