2017 iMac - TBT4-HUB3C Not Working with Monterey macOS 12.0.1

Just purchased TBT-HUB3C for a 2017 iMac with Monterey macOS 12.0.1 already installed. Hub delivers power, but no connectivity. Just wanted to report this as an issue. I plan to wait for 12.1 to see if that release fixes the problem. If it doesn’t, I’d welcome advice for next steps on how to address the problem.

Hi Steve,

Thank you for posting! I am sorry things are not working as expected while using your Plugable TBT4-HUB3C Thunderbolt 4 hub in conjunction with your iMac and I would be happy to help.

Thank you as well for the detail you provided that is much appreciated.

Based on your description of the behavior I have a few quick questions for you:

  1. Can you please confirm that you are using only the 0.8 meter long 40Gbps Thunderbolt 4 cable we included in the box with the TBT4-HUB3C hub in order to connect the hub directly to one of your iMac’s built-in Thunderbolt 3 ports? For your reference, the Plugable cable has a small white cable tag that identifies it.

I ask because other cables can cause problems. For example, the white USB-C cable that Apple includes with many of their PCs is not a Thunderbolt 4 cable, so it cannot be used for this purpose.

  1. Can you please confirm that the original Plugable Thunderbolt 4 cable is connected to the single Thunderbolt 4 host connection port located on the front of the hub? This is the port with the small laptop icon and ‘60W’ printed in text above it (60W denotes the hub’s host charging capability).

I ask because the hub will not work if the Thunderbolt 4 cable from the host PC is connected to any of the three ‘downstream’ Thunderbolt ports located on the back side of the hub (the three ‘downstream’ ports are where the external peripherals should be connected).

Apologies again for the frustration, and thank you for giving us the chance to help!

Plugable Technologies

Hi Bob! Thanks for the response and suggestions. No need for you to apologize. Rather, please accept my apologies! I was using the original Thunderbolt 4 to connect to an iMac, but was keeping the front connection open for convenience. I just updated to macOS 12.1, and the hub now works. This was for sure my error. Thanks again.

Hi Steve,

Thank you for getting back to us with the update!

My impression based on your description is that the included Thunderbolt 4 cable was not in fact connected in the manner I described in my previous question #2. After reconnecting the Thunderbolt 4 cable as suggested in question #2, the TBT4-HUB3C hub worked as expected.

Can you please confirm that my impression is correct? Apologies in advance if the question appears in any way redundant, however I just want to ensure I have the details correct and not make any incorrect assumptions.

Presuming for the moment that my impression is indeed correct, I am glad to hear that the hub is now working as expected.

A quick note, I recognize that you also updated your system to macOS version 12.1 (released yesterday, 12/13). For reference, we would also expect that the hub will work with systems running macOS 12.01 (note the ‘.01’ as opposed to ‘.1’). In other words, at this time we would not expect the macOS version difference to have been a contributor to the original behavior.

Thank you,



I’m using the original cable that came with the pluggable package, and recently upgraded to Monterey 12.0.1. My third monitor isn’t working anymore. The cable is plugged in the back of the hub.

MacBook Pro 2018



Hi Bob, so sorry for the delay! Yes, the hub works great, both with 12.01 and 12.1. Your impression was definitely correct, and your diagnosis solved the problem. The computer must use a Thunderbolt 4 cable connected to the single port at the front of the unit. Only the three ports at the back of the unit (next to the power supply connector) are for downstream peripherals.

I was able to get my third monitor to work now. I had to restart the laptop twice after the OS upgrade.

Thanks! Happy Holiday!

Hi Steve,

Thank you for getting back to us with the confirmation of our understanding, and there are certainly no apologies necessary in regard to the time frame. We appreciate you taking the time to help ‘close the loop’ on this particular thread in regard to your TBT4-HUB3C hub.

Thank you,


Hi Jennifer,

While I cannot be absolutely sure, based on your description it sounds like you may not be using a Plugable TBT4-HUB3C hub (the product that the original poster Steve was using) and are in fact using a different model Plugable product.

That detail aside, I am glad to hear that everything is now working as expected. Should you require any assistance in the future, please reach out to us directly via support@plugable.com and we will be happy to help.

Thank you,