2 - USB to Serial Adapters on Windows XP Recognizing Wrong Port After Setup


#1

I have 2 - USB to Serial Adapters on Win XP. I had one software setup to use with one adapter and after adding the second adapter and telling the second software which port to use the first piece of software will not communicate with it’s device. The error I get states that COM2 is being used by another device. In the device manager each one has been set up on a separate COM port.

Does anyone know how to get these devices to work together? Both adapters are “plugable” brand from Amazon. !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/905538/photo_inline.JPG?1369747207)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/905538/photo.JPG?1369747207)


#2

Hi Rob,

Thank you for contacting Plugable about your USB to Serial Adapters. I’m sorry to hear they aren’t working properly together on your XP computer.

We haven’t seen this error before, but that could be because we don’t get a lot of support requests for multiple devices on XP. I’m going to be doing some testing on our XP machine to see if I can reproduce the error.

I’ll post the results of my testing. In the meantime, if there are any special steps you took that would help me reproduce the problem, please let me know.

Thank you,

David
Plugable Support


#3

Hi Rob,

Here is one possible cause. Could you check for this?

Windows XP sometimes detects some serial devices as plug-and-play serial
pointing devices.

Check in device manager for the presence of serial pointing devices, and
check which comm port they are using. If you find one, click properties and
choose disable. If you delete it Windows will re-install it.

Thank you.

Also, I just wanted to verify that the software you are using, SMC60WIN supports using running multiple instances and comm ports at the same time. I installed it on our XP computer, and a single instance seems to allow only one comm port to be set. I wonder that when you try to open a second instance and set a new comm port, it causes a conflict on the comm port that is set for the first instance that is running.

Best regards,
David

David


#4

David,

Thanks for your help. I will need to look into the serial pointing devices.
As for the SMC60WIN I really don’t know anything about it. I inherited all this equipment and software a couple of years ago when I took over this project from an employee who left.

The other software I am using is called Wedgelink Lite. It allows me to download data from a data collection box to MS Excel. I had to go in using device manager and manually pick the COM port that I wanted this equipment to communicate on. Since I knew that SMC60WIN was operating on COM2 I select COM7 which seemed to be the next available port.

If SMC60WIN is a single instance software does that mean that there isn’t a way to run both devices on one machine?

Since my post above I went back to my 2 pc method to be able to run my equipment.


#5

Hi Rob,

I see. You are not running two instances of SMC60WIN. Instead you are running an instance of SMC60WIN and an instance of Wedgelink Lite and setting a different COM port that corresponds to the COM port that is set in device manager for the USB to Serial adapter that is connected to the data collection box? You would think that since SMC60WIN and Wedgelink Lite are different programs, each could independently access their appropriate COM port without affecting the other COM port or software.

I installed the evaluation version of Wedgelink on our XP computer, but when I tried to start it, it wouldn’t start. It gave an error message about the application not being configured properly. So I won’t be able to test your setup directly.

One thing I should mention, is that when you plug in each additional USB to Serial cable, you should see in device manager that it is assigned a unique COM port. You shouldn’t have to change that in device manager. For example, on my XP machine, the first one was assigned COM port 4 and the second was assigned port 5. Of course you can change these, but you shouldn’t have to. Here is a screenshot of how it looks in my device manager. Do you see something different?

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/905730/prolificUSB-to-SerialDM_inline.JPG?1369776248)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/905730/prolificUSB-to-SerialDM.JPG?1369776248)

Thank you for working with us on this.

David


#6

You would be correct. I am running an instance of each of those softwares. Within the SMC60WIN I had to tell the software which COM port to use and I used the port that was shown in the device manager which was COM2. After getting that to work I plugged in the second usb to serial adapter for the data collection box. I have to do the same thing for this device as well. I went in and had to tell the software which COM port to use which was COM7. If I go into the device manager and look under ports as you have shown. In the description, the parentheses it lists COM7 for both devices. I do not recall having to change this in device manager, only in the software.


#7

Hi Rob,
Thank you for working with us on this. Could you try plugging in both USB to Serial adapters and check Device Manager before starting the software, and verify that they both have independent ports. Then you could you check DM again each time after starting and making settings in each program? I want to make sure the software (probably the Wedgelink) isn’t somehow affecting the port settings.

Thank you,
David


#8

Hi David,

Here is the screen captures for what the COM ports show in the device manager without the software running. It is no different after you start the software. The other two images are when you right click on the port in the device manager and select properties. Then select the second tab and choose the Advanced button on that page. I have not changed these ports. This is how the laptop set these up. I only have chosen the port in the respective software.

DEVICE MANAGER
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/906102/DeviceManager_inline.jpg?1369848145)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/906102/DeviceManager.jpg?1369848145)

SMC60WIN COM Port
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/906104/SMC60WINCOMPort_inline.jpg?1369848171)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/906104/SMC60WINCOMPort.jpg?1369848171)

WedgeLink Lite COM Port
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/906105/WedgeLinkLiteCOMPort_inline.jpg?1369848248)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/906105/WedgeLinkLiteCOMPort.jpg?1369848248)


#9

Hi Rob,

Thank you for the screenshots. It is strange that Device Manager is showing COM port 7 for the first USB to Serial adapter, when it is actually connected to COM 2. Definitely, something is not right.

A couple more things to check:

Are you plugging the adapters to a hub? If so, could you try it without the hub?

Also, could you try different USB ports on the computer, and see if that changes anything?

Finally, could you try starting the Wedgelink software first, and then setting a different com port for the SMC60WIN software?

Thanks,

David


#10

Hi David,

I appreciate all your help. I apologize for not getting back to you on your above request. I will give them a shot today and update you with what I find.

Thanks
Rob


#11

Hi David,

When I started to have these issues I had the two adapters plugged into USB ports directly next to one another.

Today I went in and tried plugging one of the adapters into the third USB port I have on this laptop. Everything worked as I had hoped it would. In addition I tried this using a USB hub and had the same working results as long as I kept one adapter plugged into the hub and the other plugged directly into a laptop USB. I also tried plugging the adapters next to one another in the USB hub and I had the same issue as when the adapters were plugged into USB ports directly next to one another.

I spoke with one of our members of IT and showed him how the two adapters show up as the same COM in the device manager. He said that typically that shouldn’t happen but because they are identical devices using the same driver that could have something to do with it.

Long strory short I was able to get 1 laptop to control the two devices which was the goal from the beginning. Thank you for suggesting trying a different USB port. As simple as that option sounds I had truly over looked it.

Thank you.


#12

Great! I’m glad it worked. Thanks again for contacting us. Now we’ll know what to do if this issue ever shows up again.

David


#13