2 Different Surface Pro 6 - not connecting

Surface Pro 6, 1 personal, 1 for work - Work is mostly always connected to displays
Monitors - Dell D2719HGF x 2 - connected via HDMI
1 USB dongle for Logitech mouse - M510

Purchased UD-6950H 3 months ago. Worked perfectly until this weekend. No signal detected on either monitor. USB Mouse not working. There is power to the unit.
I have used the DisplayLink Installation Cleaner and reinstalled drivers (9.2MO) on both SP6s
I purchased another UD-6950H this week and have the same result… PLEASE ADVISE.

Hi Douglas,

Thanks for contacting us! I am sorry this is not working as expected with either docking station.

To confirm, when you setup the second docking station did you use the new Power Supply and USB cable provided with the docking station?

Based on your description of the behavior, our first step is to get some additional information from one of your systems.

If you would, please keep the Surface connected to the dock with both monitors attached (even though they are not working) and attach the output of our diagnostic utility PlugDebug ( http://plugable.com/support/plugdebug ) to an email to ‘support@plugable.com’ with the subject line ‘Ticket #280247 - Attention Pat’ as this will allow us to examine some log files from your system to help determine the next steps.

Thanks,

Pat
Plugable Technology
support@plugable.com

Thank your for the support.

Yes, used all new power supply and usb-c cable.

I will get this going on my personal SP6…work will not allow it…

Hi Douglas,

Thanks for sending us the log files for both docking stations. Unfortunately the system is not detecting the USB components ( DisplayLink Chipset, or USB Hubs ) for either docking station.

Does the USB port on the Microsoft Surface work with other USB devices, for example a USB 2.0 mouse or keyboard, or a USB 3.0 external hard drive or thumb drive?

Thank you,

Pat
Plugable Technology
support@plugable.com

yes. If i plug the mouse dongle in, it sees it immediately.