16-in-1 dock, display port not working

I’m switching docks from an old Dell TB16 and this new dock, the only thing not working is one of my monitors running off Display Port. It previously worked with this laptop with a different dock so I’m trying to figure out why it wouldn’t work with this new TBT4-UDZ dock.

3 AOC monitors using DVI connections, two converting HDMI to DVI, one converting Display Port to DVI (not functioning)

I’ve uninstalled/cleaned using Display Link but still no dice.

Laptop is a Legion 7i, new, 3080Ti in case it matters.

For more info, the specific monitors (3) are AOC I2267FW


Thank you for posting!

We can see that you also reached out to us directly via support@plugable.com to report the same issue.

In an effort to help keep all communication in one place, moving forward we will only reply to you directly, and we have just sent you our first direct reply.

Once the issue has been resolved, we will update this thread for the benefit of others following this topic.

Apologies again for the frustration, and thank you for giving us the chance to help!

Plugable Technologies

For the benefit any others following this topic, the cause of the issue in this specific case was that a Passive DisplayPort to DVI adapter was being used to connect the non-working display to one of the docking station’s DisplayPort video outputs.

Passive video adapters are not compatible with the TBT4-UDZ. If the DisplayPort video output needs to be converted to a different protocol, then an ‘Active’ adapter must be used.

We speak to this in more detail under the ‘Important Notes’ section within this knowledge base article → https://kb.plugable.com/question/1705024

Thank you,