10m active extension cable disconnects (Mac Lion, powered USB drive)


#1

Hi, I’m using plugable 10 port USB hub with MakBook pro 4.1, Lion OS. Hubg power adapter is connected. I have connected powered Maxtor USB drive to it where I host Time Machine. It worked fine for a long time (a few months)

Recently I bought plugable 10 m active extension cable and connected it between hub and maxtor. Immediately I started getting Drive Disconnected message about every few hours from macos suggesting to eject it safely next time. The log also contains “media not present” errors and out of sync filesystem notifications for that drive.

What could be the problem? (I don’t think it is insufficient power related since all devices involved are powered).

Any suggestion?

Thanks
Alex


#2

Hi Alex,

I’ve sent a response to your question directly from our private support system. Look for an e-mail from support@plugable.com. We’ll use that channel as the means to continue the support conversation, and once we find a solution, I’ll update this public post with the solution for the benefit of anyone searching our support site.

Best Regards,

Aaron
Plugable Technologies


#3

For the beneficiaries of any future viewers of this issue, the configuration failed when it was like this:

computer > self-powered hub > 10M cable > drive

It worked when we changed it to

computer > 10M cable > self-powered hub > drive

If you encounter a similar situation, try reversing the order of the cable and the hub.

Our conjecture is that even though the drive was self-powered, it still was looking to draw power from the USB connection and wanted more than was available after the cable drew its share of the available power for its active repeater.


#4