Windows 8 remote connection (RDP) to windows 7 computer


#1

We set up a laptop today running Windows 7 to do a remote desktop connection via RDP to a work computer also running windows 7. We tried doing the same setup on a laptop running Windows 8. We tried to connect using the laptop running Windows 8, but we could not get the two monitors to work. We did everything the same in terms of the display settings.

Are there issues with Windows 8 machines connecting to Windows 7 machines via RDP?

Thanks.


#2

Hi Scott,

Thanks for posting. Generally Win 8 RDP to 7 should work with multiple monitors, assuming that the Win 7 system is the Enterprise version, which is the only one that supports multi-mon RDP. (And I assume it is the Enterprise sku, since your other system is able to RDP in with multi-mon.)

Are you using a Plugable docking station or USB graphics adapter on the Windows 8 laptop? If so, which model? If a USB graphics adapter is in use, are you able to remove it and test with a display directly connected to the laptop to see if you still fail to get two monitors via RDP?

Thanks!
Gary


#3

Thank you for your reply. I should have stated we are using the plugable UD-3900 USB 3.0.

I am not sure what you mean by " If a USB graphics adapter is in use, are you able to remove it and test with a display directly connected to the laptop to see if you still fail to get two monitors via RDP?"

We are using the UD-3900, which is connected to the monitors, and the laptop is connected to the UD-3900. Like I said in my original post, it worked fine for a windows 7 laptop, but failed to work for the Windows 8 laptop.


#4

Hi Scott,

Appreciate the clarification!

Regarding what I’d mentioned about “I If a USB graphics adapter is in use, are you able to remove it and test with a display directly connected to the laptop to see if you still fail to get two monitors via RDP?” - essentially I’m wondering if it’s possible to test the RDP connection with the UD-3900 disconnected, and instead connect a second display up to the laptop directly.

This will of course be contingent on whether or not you have an additional display output on the laptop that can be used for these tests.

If we’re able to test in the proposed configuration, it will let us know if the behavior is only present when the UD-3900 is being used for multi-display output, or if the behavior is present with any multi-display configuration, regardless of whether the UD-3900 is being used.

Thanks!
Gary


#5

I don’t have the option to directly connect to a second monitor.

Here is what worked for us on my laptop with windows 7. I created a new shortcut for the RDP connection to my computer at work.

In the Shortcut Tab, for “Target” I had:

C:\Windows\System32\mstsc.exe C:\Users\Scott\Desktop\Office Desktop.rdp /span /multimon

For “Start In”, I had: C:\Windows\System32 .

On the Windows 8 laptop, we did the same exact setup. However, we cannot get it to work connect at all using the shortcut. One thing i noticed is that in the RDP connection on the windows 8 machine, both monitors are recognized, because we can move the remote desktop between the monitors. The problem is the Shortcut we setup on the Windows 8 Machine does not work at all. And one the RDP shortcut, the Span feature does not work.

So essentially, we created a shortcut on the Windows 7 machine and told it to “Span” by modifying the “Target” line as indicated above. But this does not work at all for Windows 8.


#6

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1193014/Document1_inline.jpg?1429803773)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1193014/Document1.jpg?1429803773)

Here’s what my RDP shortcut looks like for the mutli monitor.


#7

And we have tried on 3 different Windows 8 laptops with no luck getting the span to work. The setup “sees” the two screens, but we cannot get spanning on the RDP.


#8

Hi Scott,

Thanks for the additional info. Doing some searching on the web, I’m seeing many people reporting that the “/span” option no longer works well as an RDP option in Win 8. (Or it works in limited circumstances such as if you have exactly matched resolution/display layout for the local and remote machines, etc.)

Any different result if you remove the “/span” argument and try with just /multimon?

Also, some people with similar symptoms reported better results setting up RDP through a GUI setup, which offers a “Use all my monitors for the remote session” check box. This is outlined in the thread below - seems like it would be worth a try to see if the results are different:

http://stackoverflow.com/questions/14…

Thanks!
Gary


#9

Gary-Thanks for all the answers. I tried your suggestions. We had already tried in the one in the link with the checkbox. Neither solution worked. I even tried going with just /span or just /multimon. We will hope for the best when Windows 10 arrives.


#10

Success!!!
Check out this link:
http://blogs.msdn.com/b/rds/archive/2…
By following the advice in point #3, namely by getting all three monitors the same size by adjusting screen resolution, I got them to span.

This is hilarious because the linked article is from 2009. The screens look ridiculously large before logging into the RDP, but the people doing this are only using two monitors to work from home. !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1193101/dc85088f-b945-450f-a780-9407794db297_inline.png?1429813045)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1193101/dc85088f-b945-450f-a780-9407794db297.png?1429813045)


#11

Hi Scott,

Ah, excellent! Amazing how sometimes an older seemingly non-relevant MSDN page comes through with a fix to an obscure problem.


#12