Windows 7 64bit - WPF Display Adapter Trouble


#1

I have usb 2.0 docking station, running on Lenovo W510, with windows 7 pro sp1. I am using the laptop’s monitor, a monitor running off the laptops display port, and a third running off the docking station.

I cannot get WPF applications to work with the monitor running off the docking station.

Specifically I would love to be able to use Visual Studio 2010.

I have tried most of the suggestions listed on this site, and nothing seems to work. please help.


#2

Hi!

Thanks for posting and sorry to hear you’re having problems with our docking station with Visual Studio 2010! We’ll get you running!

The most common cause for this is Aero being disabled. We suggest running the Windows Aero Troubleshooter - more information can be found here. This should fix most Aero issues.

It might also be worth checking which version of DisplayLink drivers you’re using. Go to Device Manager,expand ‘USB Display Adapters’ right click on your Plugable device and click Properties. Once there, click on the Driver tab. What is the Driver Version? Should look something like: 5.6.31854.0

Let us know if this helps!

Regards,
Lampros


#3

Lampros

I tried the Aero trouble shooter before, and it found no issues with my Aero configuration. I ran it again just now to make sure, and everything is still good.

I did have version 5.5 of the driver, so I updated that, but I still cannot use VS 2010 on the monitor running off the USB docking station.

What is the next step?

– Eric


#4

Hi Eric,

Thanks for the reply!

Can you confirm that you are now using 5.6 M1? The version number should be something like 5.6.31854.0 on Device Manager.

Also, if you haven’t already, can you have a look at this post and see if the suggestion to turn on ‘Enable Desktop Composition’ (look at the 4-5 posts) helps?

Let us know if this does it!

Regards,
Lampros


#5

Lampros

My driver version is: 5.6.31854.0

When I go to adjust the ‘Visual Effects’ inside the Performance Options, I currently do not have an option for ‘Enable Desktop Composition’.

I remember trying this last week, and I did have an option for the desktop Composition at that time. I’m not sure where it has gone since then. I have installed several windows updates in the past week.

Here is some additional machine info from the Windows 7 Performance Index tool:

Total Score : 6.4

Processor Intel® Core™ i7 CPU Q 820 @ 1.73GHz SubScore: 7.1
Memory (RAM) 16.0 GB SubScore: 7.4
Graphics NVIDIA Quadro FX 880M SubScore: 6.4
Gaming graphics 4607 MB Total available graphics memory SubScore: 6.4
Primary hard disk 18GB Free (108GB Total) SubScore: 6.9
Windows 7 Professional

System

Manufacturer LENOVO
Model 4318CTO
Total amount of system memory 16.0 GB RAM
System type 64-bit operating system
Number of processor cores 4

Storage

Total size of hard disk(s) 1050 GB
Disk partition (C:) 18 GB Free (108 GB Total)
Media drive (D:) CD/DVD
Media drive (F:) CD/DVD
Disk partition (P:) 9 GB Free (466 GB Total)
Disk partition (Q:) 2 GB Free (10 GB Total)
Disk partition (W:) 74 GB Free (466 GB Total)

Graphics

Display adapter type NVIDIA Quadro FX 880M
Total available graphics memory 4607 MB
Dedicated graphics memory 1024 MB
Dedicated system memory 0 MB
Shared system memory 3583 MB
Display adapter driver version 8.17.12.6721
Primary monitor resolution 1600x900
Secondary monitor resolution 1680x1050
Secondary monitor resolution 1680x1050
DirectX version DirectX 10

Network

Network Adapter Intel® 82577LM Gigabit Network Connection
Network Adapter Intel® Centrino® Advanced-N 6250 AGN
Network Adapter Intel® Centrino® WiMAX 6250
Network Adapter Microsoft Loopback Adapter
Network Adapter ASIX AX88772A USB2.0 to Fast Ethernet Adapter


#6

Lampros

Do you have any further ideas on this? Its been two days since I last heard from you.

I have noticed that my Areo transparency gets disabled automatically when I use the USB docking station. Maybe this is part of the issue.

Thanks for your help

– Eric


#7

Hi Eric,

Sorry for taking so long to get back to you!

You mentioned that the Aero transparency gets disabled automatically when you use the docking station. At that point, if you run the Aero troubleshooter does it reports and fixes the problem?

When you try to run Visual Studio 2010 and see the problem, at that point is Aero disabled or is it still running?

There’s a history of problems with Visual Studio 2010, we expect to be able to find a solution for you once we understand what is disabling Aero.

Regards,
Lampros


#8

Lampros

after Aero transparency gets disabled automatically, if I run the troubleshooter it says there are no issues.

When I run VS 2010 Aero is still running (i think) but with transparency automatically disabled. I only have the VS issue on the monitor running off the usb hub. The laptop screen and the other screen running off the laptop’s 2nd monitor output display VS with no issues, but also do not have transparency.

Both monitors using the laptops video card also run VS without issue (and with transparency) when the hub is disconnected.

It seems like transparency is disabled as a result of attaching the Hub.

Ideally I’d prefer to be able to use VS on the Hub based monitor without Aero, as I’m not a big fan of the transparency effect, and rather not waste cpu on it.

I’m going to be out of the office the next few days, so I won’t be able to try any new ideas until Monday.

Have a good weekend.

– Eric


#9

Hi Eric,

We may have a workaround for you. There is a registry change you can apply to disable hardware acceleration (for WPF applications only). Could we ask you to try and apply this and see if it helps?

You can find more information on this registry change here.

Let us know if you need any help applying this and if it made a difference to your problem!

Regards,
Lampros


#10

Lampros

This solution seems to work for me.

Note that I had to manually add the Graphics.Avalon Key and the DisableHWAcceleration dword entry. Neither existed in my registry by default.

Please let me know in the future if you release a driver update that supports hardware rendering for VS 2010 and other WPF applications.

Thanks for the help.

– Eric


#11

Hi Eric!

Glad we could be of assistance!

Thank you for the detailed reply, we’re really not sure why the previous solutions didn’t work for your system, hopefully it will be something that will be resolved with the next release of the DisplayLink drivers.

We’ll certainly keep you posted!

Have a great day!

Lampros


#12

Lampros

I just found a new way to fix this issue, specifically for Visual Studio 2010.

Inside Visual Studio 2010 there is an option to disable hardware rendering for that application only. This fixes the issue without any other changes.

To get to the option follow this path:

Tools -> Options -> Show All Settings -> Environment -> General -> Visual Experience

Uncheck “Automatically adjust visual experience based on client performance”
Uncheck “Use hardware graphics acceleration if available.”

Hopefully this helps other users.

– Eric


#13

Eric!!

Can’t believe the solution was actually so easy, thank you very much for that, we’ll definitely keep it handy, and we’re certain it will help other users in the future avoiding the need for ugly ‘hacks’ !

Have a great week!

Regards,
Lampros


#14