Widnows works, Macbook Pro does not

I have a UD-3000 USB 3.0 hub that works great with my Windows computers - Surface and tower. My set up is with two monitors and I use the laptop as a third monitor. No issues with Windows. However, I just bought a MacBook Pro, downloaded and installed the Displaylink drivers, and the MacBook does not recognize my two monitors. Keyboard, mouse, speakers all work, but not the monitors. I am using a USB A to USB C adapter. Any thoughts?

Hi Gregory, thanks for posting and I will be happy to help!

Thanks for the description of the behavior you are seeing. Do other USB devices (like a keyboard, mouse or flash drive) work when connecting to the USB-A to USB-C adapter you’re using?

Assuming that other USB device are recognized using the USB-A to USB-C adapter, and if possible, would you be able to send us a log from from one of your Windows systems to determine the firmware version that the dock is running? A firmware update may be available in order to see if it helps on your new MacBook Pro. To help us do so please download and run our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug on one of the working Windows systems and please send the file created on your Desktop to support@plugable.com directly with 'Ticket Number 209524" in the subject line and we’ll match everything up.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support

I actually figured it out form another forum thread. I needed to allow the DisplayLink drivers through the Apple Security and Privacy section. After I did that and rebooted, it works like a champ! Thanks for getting back to me!

Gregg

Hi Gregg,

Thanks for the reply and great to hear that you were able to resolve this issue!

Thank you,

David W.
Plugable Technologies
www.plugable.com/support