WI-FI Connectivity Issue


#1

When I connect my Surface 3 device using the Surface Pro 3 docking station to the Plugable UD-3900, I intermittently lose connectivity with my Wi-Fi router. I don’t experience the same Wi-Fi connectivity issue when the Surface 3 is not docked so I believe I have isolated this issue to the Plugable device.

I attempted to move the Plugable UD-3900 to a new location on my desk and that did not resolve the issue. In addition, I tried moving the connection from a USB 3.0 to USB 2.0 port on the docking station and this did not resolve this issue. Any other suggestions?


#2

Hi Michael,

Thanks for reaching out to us, I’d be more than happy to assist you with your Plugable UD-3900 docking station. In order to do so, we’ll need some additional information.

First, if you connect the UD-3900 directly to the Surface Pro 3 (USB 3.0 port on the Surface Pro 3) does the same intermittent wireless problem occur?

Second, if you connect the UD-3900 when the Surface Pro 3 is not docked to the Surface docking station are there wireless issues?

Third, can you please try completely reinstalling the DisplayLink drivers by following these steps:

  1. Disconnect the adapter from the computer.

  2. Run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  3. Download driver v7.7 M0 from the below link and follow the installation prompts.
    http://www.displaylink.com/support/sl…

  4. Reboot the computer.

  5. Replug the adapter to the computer. Allow several minutes for the driver to enumerate and for the firmware upgrade to complete.

Once that is done, can you run our log gathering tool Plugdebug. Simply go to this site, follow the prompts there, and send us the resulting .zip file at support@plugable.com.
www.plugable.com/plugdebug

Regards,

Stephen
Plugable Technologies


#3