WD 1TB USB 3.0 Passport drive not working with Win7, USB 3.0 card


#1

I just installed the PCI-X USB 3.0 card into my HP 6200 Pro SFF desktop. I used the 4-pin power cord to SATA power cable. When I powered it up to Windows 7 Enterprise x64 SP1, it found the card in Device Manager. I downloaded the latest drivers from here and they installed just fine. Two Renesas devices are listed correctly under the USB tree.

I plugged in my WD 1TB Passport USB 3.0 external, portable drive, but ti doesn’t work. The drive is spinned up, but no activity. Nothing in Device Manager, nothing banged out. I unplug it and plug it back in, nothing.

What am I doing wrong?

Thank you!

Michael R.


#2

Hi Michael,

Thanks for posting and for all the details. I’ll be happy to help!

First, can you test the USB 3.0 PCI-E card with a simple USB device like a mouse?

The next test to try is to see if the WD 1TB Passport works in another USB port. It’s OK if it’s USB 2.0 we just want to be sure the drive inside the enclose has a valid file system and that the hardware all works.

Also, you can start Windows Disk Management Service by typing diskmgmt.msc in the search box of the start menu.

Once in the Disk Management interface, you should see the WD external disk listed at the bottom of the screen, if it’s unallocated you’ll need to right click on it and use the options available there to format and partition the drive.

Let me know what you find,
Jerome.

Plugable Technologies


#3

Jerome,

At this point, I know for sure the WD drive DOES work on other USB ports on the same desktop. It has 8 USB2 ports.

When plugged into the USB 3.0 ports on the Plugable card, it doesn’t show in My Computer, and it doesn’t show up at all in Disk Management.

The only thing I haven’t tried yet is plugging a USB mouse into the PCI-E 3.0 card to see if it functions at all. I’ll be back at work on Monday afternoon and I’ll reply back then.

Thank you for your help.

Michael


#4

Jerome,

I plugged in a simple USB mouse. Windows 7 showed a new hardware wizard, it showed it getting software from Windows Update, and then it said Ready to Use. However, the red light on the optical mouse, which was on, went off, and the mouse did not work.

I plugged the mouse into the fron USB ports, and it worked fine. So, both the mouse and HD worked on the front ports, but both devices do NOT work when plugged into the USB 3.0 card.

Please advise on what I can do.

Thank you.

Michael R.


#5

Hi Michael,

Thanks for checking out the mouse on your USB 3.0 card. Sorry to hear that it didn’t work. In looking at the specs for your system (HP 6200 Pro SFF), two things jump out. The first is the small form factor of you system. Double check that the shorter of the two face plates is installed on the card. This allows the card to seat all the way into the slot.

The second and more significant issue is the slot type. The Plugable USB 3.0 PCI-e card is designed to work in a PCI-e X1 slot, and usually works in X4 slots as well. In looking at the tech specs for your machine, it looks like it has an X16 slot only and unfortunately these usually don’t work. On some systems you change the speed of the slot in BIOS, if possible try changing the setting downward.

Check these two things for me and let me know how it goes. If there’s no improvement, and there’s no way to lower the speed, please forward your Amazon Order ID, & the serial number of your card to support@plugable.com and we’ll get you fixed up.

Thanks for your patience,

Jerome

Plugable Technologies


#6

These are the slots available in the attached PIC. So, the only x1 slot is Conventional PCI. Is it because the only PCI-Express card is an x16?

If this is the case, am I out of luck?

Thank you.

Michael R. !](https://s3.amazonaws.com/satisfaction-production/s3_images/690145/Capture_inline.PNG)](https://s3.amazonaws.com/satisfaction-production/s3_images/690145/Capture.PNG)


#7

Hi Michael,

Unfortunately, the conventional PCI slots aren’t compatible with PCI-e. Just to be sure, I’d check the face plate we’ve seen systems where they look like they are fully seated and the lights are on but the card won’t work. It’s worth a shot to check in the BIOS for a way to lower the speed. Otherwise I’m afraid it’s not compatible.

Send over your order info and serial if that is indeed the case to support@plugable.com.

Sorry I don’t have better news,

Jerome.

Plugable Technologies


#8

Yes, I remember attaching the low profile bracket. Plus, the two devices appear in Device Manager:
!](https://s3.amazonaws.com/satisfaction-production/s3_images/690885/Capture_inline.JPG)](https://s3.amazonaws.com/satisfaction-production/s3_images/690885/Capture.JPG)

Not sure how it would be detected and have blue lights if it wasn’t seated.

Anyway, I’ll send the order details to the email address.

Michael


#9

Hi Michael,

It’s strange that the card can be detected and lit up with out being fully seated but it is something we have seen. It’s good to know that you have the correct bracket installed. I’m afraid it’s the X16 slot that’s the culprit in this case.

We’ll be sure you can get a refund.

Thanks again,
Jerome.

Plugable Technologies


#10