Very poor speeds in Windows 10. Works fine in MacOS or Linux


#1

Using a Samsung 970 Evo 1TB, I am only getting 40Mbps in Windows 10 on my desktop with the provided USB C - > USB - C cable. I have tried on my desktop computer connected directly to the USB-C port on my ASUS motherboard. I also tried on the USB-C port on my NVIDIA GEFORCE 2080 TI video card. I have also tried on my laptop, a Razer Blade 15 which has a Thunderbolt 3 port. All give me the same result, 40Mbps. On the Razer Blade 15 the drive can’t stay connected, it keeps disconnecting on its own. If I use the included USB-C to USB-A cable, the problem continues.

If I use the drive on a Macbook Pro, it seems to works fine.


#2

Hello,

Thank you for your post regarding the performance of your Plugable USBC-NVME enclosure.

I’m sorry to hear about the performance problems you’re experiencing when using your SSD on Windows 10. I would like to help.

Microsoft recently made changes in the behavior of USB media in Windows 10 to favor quick and easy removal over performance.

To start with, could you please try changing the SSD from Quick Removal mode to Performance mode and see if this results in an improvement?

More information how to make this settings adjustment can be found on Microsoft’s website.

If this doesn’t seem to help I can help to gather more information to better assist.

Thanks!