Very out of Range X Coordinates on USB VGA Adaptor


#1

I have tried multiple USB adapters, and recently purchased a Plugable SuperSpeed USB 3.0 USB-VGA adapter, because it said it was Windows 8 compatible. But I keep having the same issue where the X coordinate was millions of pixels away from the next monitor. Is there a way to change this manually, or some other way to fix this problem? If I take a screen shot, it shows the background of the monitor, and when I enable the other monitor, it responds with the power light turning green, but just shows a black screen.

Addendum:
I disabled the onboard video because it wasn’t compatible with a program I sorely need to use. So I bought an NVidia card that was compatible, and that shows up as Screen 2, and the USB-VGA adapter is Screen 3.
Codeman !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/916666/displaylinkxcoordinate_inline.JPG?1372020417)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/916666/displaylinkxcoordinate.JPG?1372020417)


#2

Hi Cody,

Thanks for posting! That’s frustrating (and interesting - I’ve never seen a monitor be given a crazy position like that by Windows).

Windows 7 and 8 stores a separate configuration of monitor position(s) for every unique combination of monitors that has been connected to the system. The EDID returned by the monitor is used to uniquely identify it.

So if you attach an extra monitor (or remove one or change one out), it’s a different configuration, and Windows will start again from default settings.

All these settings, for every combination of monitors, is stored in the registry at
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

So what I’d do is this:

  1. If you simply move monitor 3 to the left of monitor 2, does Windows assign a rational position to it? Does it solve the issue?

  2. If not, if you delete all the registry entries (one per monitor combination) at
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration and then unplug/replug the monitor and set the monitor position again from scratch - does that resolve the issue?

If not, I’d recommend sending DisplayLink logs to see if there is anything that can be done (e.g. a different nVidia driver) that could solve the issue. Here’s how to do that:
http://plugable.com/support/tools/dis…

Hope we get lucky and the early steps help - but either way we’ll work to get to the bottom of it.

Thanks again!
Bernie


#3

No dice.

http://www.friscorr.com/cody/MSTS_201…


#4

Hi Cody,

It’s very tempting to try to remove that add-in card and try with the on-board video only. But I know that’s a pain.

So first, let’s just try to completely uninstall and re-install the DisplayLink drivers to the newly released version, just on the off chance that helps.

Here’s how to thoroughly uninstall:
http://www.displaylink.com/support/ti…

Please do the step of running the cleaner utility mentioned there.

Then install the latest 7.3M0 drivers, available here:
http://www.displaylink.com/support/do…

And reboot and let us know if that helps. If not, we may need to check behavior with the onboard (without nvidia). Thanks!

Bernie


#5

I did that today, even before you wrote your reply. Still no dice. If I understand some of the other forums I have been reading, if I disable UEFI, then my onboard video should be compatible with Microsoft Train Simulator. I tried once, but that was with my nVidia card still in. It caused a startup error, and the computer wouldn’t start. On my next day off, I will shut it down, take out the card, restart, and disable UEFI to see if the game is actually compatible with my ATI onboard video. If it is, I will try adding my USB Display adaptors one by one to see if they will work.
Cody


#6

Thanks Cody! That’s the right next step. Please let us know if there’s a way we can help. Thanks again!


#7