USB Mouse no longer working through UD-3000 but does work plugged in to laptop


#1

Hi, I have been running with my USB 3.0 docking station UD-3000 with no issues. Following a power down of everything, my USB Logitech Trackball mouse no longer worked through the UD-3000. It does work when plugged directly into my laptop port. I have tried to reinstall its drivers but the problem remains.


#2

Hi Charles,

Thanks for posting your question here, we’d be glad to help! Let’s start with a couple of simple troubleshooting steps to narrow down the issue:

  1. With the dock still connected to the computer and mouse plugged in, unplug the power adapter to the dock and plug back in. Does this make a difference?
  2. Do you have any other devices connected to the dock? If not try connecting another USB device, does it have the same problem as the mouse?
  3. Connect the dock to a different USB port on your computer, does that make a difference?

You can reply back to us directly at support@plugable.com and we’ll get you sorted!

Thanks,
Ellen


#3