USB Device Not Recognized


#1

I just bought this device and am working through some issues. The usb ports on the device seem to be working but the monitor is not and the network adapter doesn’t seem to be working either. I’ve unistalled the driver, cleaned, rebooted and reinstalled the driver as recommended, but each time I plug in the device, I get USB device not recognized. I’ve tried disconnecting everything, and plugging it in and I still get the error.

Any help would be appreciated.


#2

Hi Mike,

Thanks for posting!

Based on your description, I’d like to request some logs from your system in order to investigate further. You may have seen that we have a diagnostic utility that helps us understand more about what could be going on in situations such as these. Could you please keep the UD-3900 dock connected to your system, then navigate to our PlugDebug tool (https://plugable.com/support/plugdebug) and follow the instructions there?

This will create a ZIP file on your Desktop containing system logs and information. Please send this ZIP file to us directly at support@plugable.com with the subject line: “Ticket #264469

Thanks for giving us a chance to help!

Mitchell


closed #3

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.