USB-C E-1000 Ethernet adapter not working on 2016 MacBook Pro (4 USB-C ports model)


#1

I’ve got a 2016 MacBook Pro, the model with the TouchBar. Your USB-C to Ethernet adapter doesn’t work on it at all. When I plug it in to the Mac, there’s no Ethernet light. In the Network preference pane, there no sign of the hardware being present in the list of network connections.

I have installed the latest driver, and still no luck. I’ve tried it in two different routers, without success.


#2

Hello Dwight,

Thanks for reaching out and posting on our Get Satisfaction forums, and I apologize for the issue you’re experiencing! If your Macbook is on the High Sierra update (macOS 10.13), after installing the drivers for the adapter you will need to go into the Privacy & Security settings to allow the driver to be loaded by the Macbook. More information on this issue and steps on how to resolve it can be found here:

https://plugable.com/2017/10/27/how-t…

If this doesn’t appear to be the issue and there is nothing to be allowed through in the Privacy & Security settings, can you send an email to support@plugable.com with a copy of your system report? You can gather this by clicking the Apple icon in the upper left and selecting ‘About This Mac’, then click the button for ‘System Report’. To save a copy, click File > Save and send the saved file to us. With that information, I should be able to get a better understanding of the issue and what we could do to resolve the issue.

Let me know if you have any questions, and I look forward to working with you on this issue!

Regards,

Patrick
Plugable Technologies
www.plugable.com/support


#3