USB Audio MacOS Stutter/Skip


#1

Hello,

I’m using a UD-3900 as a general USB 3.0 dock and I’d like to use it for my headphones as well, but the output has tons of stutter/skip. I’m NOT using the dock for any sort of video output, if that matters. Any audio output (typically music) to my headphones produces significant stutter when plugged into the UD-3000. When I switch over to the audio port on the macbook, the sound is pristine.

I do realize this dock is not officially supported with MacOS, but I’m curious if there any other reports of USB audio issues and if there are any settings to tweak. I do have the latest DisplayLink drivers installed (2017-09) so I don’t think software is the issue.

I’m running MacOS 10.12.6 on a new macbook pro, if that matters.


#2

Hi Michael,

Thank you so much for reaching out to us, I am sorry to hear that you are running into this issue, but I would be happy to assist!

Based on the description of the issue, I just want to clarify a couple of things. Does this issue occur with specific headphones or speakers, or any that you connect?

Also, when you have a moment, could you please send your Amazon Order ID Number via a direct email to support@plugable.com, as I would like to review the time in which you purchased the docking station. Could you also include the serial number of the docking station located on the bottom of the docking station?

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Hi Marc,

Yes, I’ve tested with two different sets of headphones and both exhibit the problem. The built-in audio jack on the laptop never has the issue with any headphones. I’ve sent the other information via email, as requested. Thanks for looking into this.


#4

Hi Michael,

Thank you so much for taking the time to email the order information and serial number over. I suspected that we may have been dealing with an older dock FW, but I do not think this is the case with your unit. Has this issue just started to crop up, or has it been this way since you first connected and utilized the docking station?

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#5

I’ve only had the dock for 1 month (appx.) and it’s always had the audio issue. I suspect this is either a MacOS issue OR something with the driver that plugable is providing in the download package. Let me know if there is some way I can narrow it down more. Thanks.


#6

Hi Michael,

Thank you for letting me know! This individual dock does not have this as a common issue, and instead has normally performed very well on Mac systems (I happen to use the same chipset on my own Mac and work and home) and do not run into the same issue. We have seen issues related to utilizing Apple based headphones when connected, just due to how the specific Apple 3.5 jack is oriented, but since this same issue occurs with multiple headsets, does not occur when directly connected, then most likely it could be a faulty docking station or audio port. When you installed the docking station, did you install the latest version of the DisplayLink drivers from DisplayLink.com or our site? Are you still on Sierra or High Sierra currently?

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#7

Hi,

I’m running MacOS 10.12.6 (latest Sierra). I have not upgraded to High Sierra. Yes, I installed the latest software package from the download site (ver 4.0.0). Just for good measure, I went ahead and uninstalled, rebooted, and reinstalled the latest version that is listed on the downloads page, and finally rebooted one more time. Audio stutter still exists after doing that.


#8

Hi Michael,

Thank you so much for working through these additional steps. With this information, I would now like to advise having a pretested replacement unit sent out. I will email over a confirmation of address to you, and let you know as soon as I receive tracking and confirmation of the pretested replacement unit be packaged and shipped.

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#9