USB 3.0 Dock disconnect frequently and most time could not be connected/detected


#1

Hi, Just bought a USB 3.0 SATA hard drive dock. Constant problem connecting directly to my USB 3.0 ports on my computer. It randomly disconnect and most time could not connect/detect. I have updated the Intel USB 3.0 driver to the latest version without any improvement. Used the USB 2.0 cable and HDD is detected and usable right away. Please advice. My Amazon order number is 002-1120438-4244203. Thanks Clifford


#2

Hi Clifford,

Thanks for contacting Plugable Support with all of the necessary details, we’ll be happy to help. I’ll contact you directly so we can get you fixed up.

Thanks,
Jerome.

Plugable Technologies


#3

Hi Jerome,

I’m having the same problem. Amazon order 108-5859240-6636225 here.


#4

Hi Tavis,

Thanks for posting here, sorry to hear you are having the same issue. Here’s a link to a troubleshooting guide for the U3.

http://plugable.com/2012/08/20/troubl…

Let me know what you find when you work through the troubleshooting guide, especially what happens with the USB 2.0 cable.

Also, can you say a bit more information about your system? I’m wondering what USB 3.0 controller and which driver version you are running. For USB 3.0 host controller driver updates can make a big difference. So we’ll definitely want to make sure you are on the latest version for your controller.

Once we hear back with these extra details, we’ll be able to figure out the best next steps.

Thanks,
Jerome.

Plugable Technologies


#5

I have this same problem too!! Except mine happens after a few min of transferring files. The drive just disappears from windows. No clue why. I’m using the integrated USB 3 ports on my Asus P8Z77-I motherboard and Samsung 7200rpm 500gb SATAIII HDD’s.

Everything works fine on USB 2, just slow.

Edit: windows 8 x64


#6

Hi eatkabab,

We’ll be happy to work with you to get your setup working.

Please email us at support@plugable.com

Thanks,
Jerome.

Plugable Technologies


#7