USB 2.0 switch fails to connect to printer


#1

On June 6, 2014 I purchased 2 USB 2.0 switches - thru Amazon

One is/was used for two computers to a scanner - so far OK
One is/was used for two computers to a color printer - originally worked as expected - now FAILURE!

I have tried all of the " cable switching" possibilities and each will work occasionally, but not regularly or reliability
In every case where I by-pass the USB 2.0 switch and manually connect the printer to each of the computers (one at a time, of course) - the printer will be activated and print

Each computer is equipped with a Plugable USB 3.0 hub - If I connect the printer thru the respective hubs, printing happens. If I connect the switch thru the hubs - nothing happens

Checked device manager - no yellow warning symbols!

I think I have at least one defective USB 2.0 switch - how do I get a replacement


#2

We worked with Michael via our email ticketing system on this issue. Posting the results below for the benefit of others who may encounter this thread.

-The two switches were swapped so that the known-good switch was moved to the printer, and the questionable switch was moved to the scanner.

-Also, there was a longer USB cable being used, which was removed for troubleshooting purposes.

-USB power management was disabled in Device Manager for the USB ports on the systems.

-After the above, it appears that things are working properly. (Though it was an intermittent issue, so long-term testing will be needed for confirmation.)


#3