USB 2.0 Docking Station / Terminal Windows 7 64 Bit


#1

I installed the latest DisplayLink 6.0 M1 software from www.displaylink.com. Then I connect the USB cable to a Dell Latitude E6320 series running Windows 7, 64 Bit. We can configure the monitor that is connected to the docking station and everything works fine until we restart the laptop. We then get a blue screen and Windows needs to run a Startup Repair (System Restore) in order to correct the issue. I have also tried installing DisplayLink 5.6 M1 with the same result.


#2

Hi Mike,

Thanks for reporting this! Sorry for the frustration - a crash like this definitely isn’t normal, so we’ll figure out what’s different about this system and get it resolved.

Two quick questions:

  1. Is there any chance this machine is running Cisco Security Agent? Cisco has discontinued this product (http://www.cisco.com/en/US/products/s…), but it has a known and unresolved conflict with DisplayLink’s drivers that result in a crash.

  2. Do you see any .dmp files in your /windows/minidump directory from the date & time of the crash? If so, if you can email them to support@plugable.com, we will be able to see the details of the crash and figure out next steps.

Again, our apologies and thanks for contacting us so we can help!
Bernie


#3

For the benefit of others …

We got the .dmp files from this system, and the crash was in a driver named mctkmd64.sys, which is from a company called MCT (Magic Control Technology) which, like DisplayLink, sells USB graphics technology. DisplayLink is dominant in terms of market share, but MCT sells under some brands like Startech and their own.

This version of MCT’s driver crashes in the presence of DisplayLink’s driver, unfortunately.

Mike was able to solve the issue by uninstalling the (MCT) drivers for a Startech dock that had been used on this system previously. All’s well now.

This is a useful general note - Because Windows (prior to Win 8) doesn’t have a driver model for USB graphics devices, they can easily step on each others’ toes. Mixing graphics drivers from the different USB technology providers (the big three are DisplayLink, SMSC, and MCT) can be problematic and is not recommend.

Feel free to contact us here or email support@plugable.com anytime if you think you’ve run across anything like this – we’ll be able to help.

Thanks,
Bernie


#4