Unable to see image on Dell Monitors after Windows 10 Home 17134.885 update

Greetings,

All was well before this update. Following the update, my dual screens are no longer detected.

Hello,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

We would recommend as a first step to do a clean install of the dock drivers and see if that helps with this situation:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step.

  3. Download, extract and run the DisplayLink cleaner tool, found here --> http://www.displaylink.com/downloads/file?d=64 and ensure it displays “Cleaning Complete”
    when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 9.1 M2 DisplayLink software, found here --> https://www.displaylink.com/downloads/file?id=1344

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please reboot the system.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies


http://plugable.com | http://performance.plugable.com/

This did not work for me.

Thanks for trying the procedure. Sorry it did not work. The next step would be, we have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Thanks!