UD-CA1 NOT working w/2017 HP Spectre x360 15.6 Kaby Lake


#1

Hello,

I ordered a Plugable UD-CA1 to use as a dock with my brand new HP Spectre x360 15.6 Kaby Lake (2017) laptop. I set up the dock consistent with the instructions and used the included USB C cable, but it will not function. When I plug in the dock cable (to my Thunderbolt 3 plug or USB C port), the laptop display and the external display keep flashing on and off in a random fashion every second or two and I am unable to use at all. Given the reports that the same exact machine in 13.3 has been working for other, I am entirely at a loss as I have tried tweaking display settings (I have tried mirror the display, extending the display, etc.) and reducing resolution to no avail.

My monitor is a Dell with HDMI inputs (Dell u2913wm - not 4k). Interestingly, my HP Spectre laptop has also an HDMI input, in addition to Thunderbolt 3 and USB C type. If I use an HDMI cable to connect my laptop directly to my monitor, everything works perfectly in extended desktop or mirror mode. Of course, I prefer to use the dock to connect using a single cable via Thunderbolt port and would any suggestions regarding if/how to get the dock to work are appreciated!


#2