UD-3900 wont connect to Ethernet or Monitors

I purchased a UD-3900 and hooked it up everything worked ethernet, monitors, keyboard, mouse. Shut everything down and nothing worked, unplugged and plugged back everything it worked again until I shut down the computer now ethernet and monitors will not work, mouse and keyboard works. I tried deleting the software and doing a cleaning like some of the posts stated, still nothing. Any ideas, defective unit?

Hi Craig,

Thank you for posting! I am sorry things are not working as expected while using your UD-3900 docking station and I would be happy to help.

Based on your description of the behavior, our next step is to get some additional information.

Please keep the dock connected to your system (even if not working as expected) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to us directly via support@plugable.com and please mention ‘For ticket 328565’ in the email subject line. This will allow us to match things up and determine the next steps.

Please also include the Amazon Order ID number for your UD-3900 purchase in your direct email, it is required to confirm warranty status.

** Please do NOT post the PlugDebug or the Amazon Order ID number here in our public forum **

Apologies again for the frustration, and thank you for giving us the chance to help!

Bob
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.