UD-3900 stopped working - suspect Windows update KB3199209


#1

I have a UD-3900 docking station that was working great until recently. The Ethernet and Display adapter do not work anymore. I think the docking station *only works* as a USB hub (haven’t checked the audio adapter)

I turned off the docking station, uninstalled the DisplayLink software, ran the cleanup tool and reinstalled the DisplayLink software and still have the same issues.

I have an old plain DisplayLink adapter (UGA-165) that works when connected to the UD-3900 as a plain USB hub. In other words, UGA-165 works but UD-3900 does not.

The only thing I can think of that has changed is that I installed the Windows update KB3199209.


#2

Hi Fabio,

Thanks for posting. I’m sorry your docking station stopped working properly and I would be happy to help.

Thanks for the great detail you provided, especially that the UGA-165 adapter is working properly with the system. Our next step is to get more information.

If you would, please keep the docking station connected (even though it is not working) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to support@plugable.com with ‘For Ticket 157734’ in the subject line. This will allow us to match everything up and examine some log files from your system to help determine the next steps.

** Please also include the Amazon Order ID for the dock purchase in your email (don’t post that here in the forum) **

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3