UD-3900 Second Monitor Flashing with Mouse Movement and Lines on Screen


#1

I just got a new UD-3900. I have a M-17 Neovo second monitor that I use with my Yoga Lenevo laptop. The problem is that every time I start it up the 2nd monitor flashes on and off as I move my mouse. It also flickers lines on it. After I change the settings through the Plugable interface for a while it stops. But if the monitor or computer do something that causes the monitor to be turned off it all happens again. I really want to use this product but this is getting upsetting trying to figure out what is wrong. Can anyone help me?


#2

Hi Jason,

Thanks for reaching out to us, I’d be more than happy to assist you with your Plugable UD-3900 docking station. In order to figure out what exactly is going on, we’ll want to get a bit of additional information.

First, how are you connecting the UD-3900 and M-17 Neovo monitor? (e.g. What type of video cable are you using, DVI/VGA/HDMI?)

Second, just to verify that the issue is not related to the DisplayLink drivers can you please completely update the DisplayLink drivers by following these steps:

  1. Disconnect the adapter from the computer.

  2. Run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  3. Download driver v7.7 M0 from the below link and follow the installation prompts.
    http://www.displaylink.com/support/sl…

  4. Reboot the computer.

  5. Replug the adapter to the computer. Allow several minutes for the driver to enumerate and for the firmware upgrade to complete.

Once that is complete, can you run our log gathering tool Plugdebug. Simply go to this site, follow the prompts there, and send the resulting .zip file to us at support@plugable.com.
www.plugable.com/plugdebug

Regards,

Stephen
Plugable Technologies


#3