UD-3900 not working: No display, no USB, no LAN

SO I set up and installed my new UD-3900 dock. Computer is a Dell Inspiron 15 7000 laptop, Win10.

Initial install failed, no connection, no video on the docked monitors. I followed directions found in other posts on this forum directing users to uninstall all programs with “displaylink” in the name (there was only one) , I Downloaded, extracted and ran the DisplayLink cleaner tool and rebooted when that was complete and
then downloaded and installed the 8.4 M2 DisplayLink software. When that was done, I powered the dock and then plugged it into the laptop. The two exernal displays came on and I was able to extend and arrange them as I liked.

I then plugged in my ethernet cable to the dock, an had no connection. No activity lights on either the dock nor the switch it was plugged into. Tried another cable, and both cables were tested good using a LAN cable checker. None of the USB ports on the docking station worked either, a mouse plugged into any of them neither showed up on the computer nor lit up. Tried a second mouse with the same result.

So I repeated the exercise above, removing the displaylink program, running the cleaner, rebooting, and reinstalling the driver. Now nothing works. no external displays, no usb ports, no LAN. Just the blue power light on the docking station. The only response I now get is a windows message saying that the USB device I connected has malfunctioned and is not recognized.

A fourth round of uninstall, run the cleaner, reinstall the drivers got both of my extended displays working again, but still no LAN or USB port connections.

Where do I go from here??


Hi Al,

Thank you for posting! I am sorry your docking station is not working as expected and I would be happy to help.

Thank you as well for the detail you provided and the testing you have performed that is much appreciated. Based on your description of the behavior, our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug –> http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 238497’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

Plugable Technologies

For the benefit of anyone else following this thread, we worked directly with Alan and have resolved both issues. In this particular case, the cause of the Ethernet adapter within the dock not working was due to the presence of an older Ethernet hub on the network (as opposed to an Ethernet switch). The Ethernet adapter in the dock is not compatible with an Ethernet hub, so once the hub was removed from the setup the Ethernet adapter within the dock worked properly.

The USB post issue described in this case was caused by a hardware fault within the unit, and we provided a pretested replacement to resolve that issue.

Please keep in mind that every case is different, and the resolution in this particular case may not be the same for others. The best practice for others is to send a PlugDebug file (http://plugable.com/support/plugdebug) to us directly via support@plugable.com as this will allow us to determine the next steps.

Thank you,


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.