UD-3900 No longer working w HP ProBook 650 - Windows 7


#1

I have the ud-3900 and it worked great for a few months. I hadn’t hooked it up in awhile (HP ProBook 650 running Windows 7), and now it won’t do anything at all. The power light it on, I installed the latest Displayport driver, tried rebooting both laptop and the hub, and nothing. When I connect the USB cable it recognizes the hub but then nothing happens. Ideas?


#2

Hi Michael,

Thanks for posting. I’m sorry your docking station stopped working with your ProBook. I’d be happy to help!

Our first step is to ensure that the DisplayLink driver used by the dock is working properly. We’ll do this by performing a clean install of the driver. Please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.
  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> http://displaylink.com/support/sla.ph…
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 7.9 M3 DisplayLink software, found here --> http://www.displaylink.com/downloads/…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system when prompted by the installer which will trigger the final portion of the installation

Please let us know if that helps, and we can go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3