UD-3900 and Surface Pro 1/WIN10 loses soft keyboard when undocked.


#1

After using a Surface Pro 1 that has been upgraded to Windows 10 when i shut it down and undock it does not display the soft keyboard to log in to the device. I have to do a reset to get it to come back. Just loaded the 7.9 driver and didn’t see any change. Any ideas?


#2

Hi Stephen,

A bit surprised we haven’t had more reports of this. After reading your post I did a bit of googling and it looks like plenty of other Surface users are reporting this behavior as well, even with the Microsoft keyboard cover for the tablet. Seems to be a major pain-point for Surface owners running Win10, so hopefully Microsoft will release a patch that fixes this sooner rather than later.

One setting to check that seems to have resolved the behavior for some users:
-Navigate to Start > Settings > Devices > Typing

-Toggle the “Automatically show the touch keyboard in windowed apps when there’s no keyboard attached to your device” to “On”

Can you give that a try and let us know if it helps?

Thanks!
Gary


#3

That didn’t help with mine. I don’t have any issue with the touch keyboard. I am wondering if it is different on the original Surface Pro versus either the 2 or 3.


#4

I found a solution of sorts. I had the setting for automatically switched from desktop to tablet mode turned on. The problem exists regardless of this setting. If I disconnect the Plugable while the Surface is on then it switches to tablet mode automatically. After that when I reboot the soft keyboard pops up automatically on the start screen. So in my case the trick is don’t shut down the Surface while connected to the Plugable.


#5

Hi Stephen,

Thanks for giving that a try. Seems like the “Automatically show the touch keyboard…” setting resolves the issue for some, not others.

Looks like Microsoft is now rolling out a second big update in as many weeks (SR2 / KB3081436). Hopefully it will resolve some of these types of tablet transition mode issues.

Thanks!
Gary


#6