UD-3000 new purchase doesn't work-computer not seeing device


#1

I purchased this device to run 2 external monitors and an external drive. I also purchased the HDMI/DVI USB Adapter.

I have a new ASUS UX31A Ultrabook with windows 8. I have read all the suggested fixes and one time when I ran the Displaylink support tool, my computer finally worked with the HUB itself. I connected my phone through the hub and it recognized the data drive. I then unplugged the USB cable and since the unplug, no go. Been fooling with this for too many hours now. Any thoughts?


#2

Hi John,

Thanks for posting and for trying those things. Because of the way things are coming and going, it may be an issue at the Intel USB 3.0 host controller driver level, with the Windows 8 built-in USB 3.0 stack – e.g. the kind of issues reflected in this thread:
http://communities.intel.com/thread/3…

But first let’s try to rule out DisplayLink’s driver as a problem – because we’ve also had cases where the DisplayLink driver on Windows 8 is not getting fully installed. DisplayLink has just today released a Windows 8 driver update which aims to solve several of these issues. Can you upgrade to that driver, reboot, and let us know if it results in any improvement? Here’s where to get the newly released 7.0 M3 driver:
http://displaylink.com/support/downlo…

Please let us know how that goes after reboot. If everything isn’t perfect, can you run DisplayLink’s support tool again, and email the .zip file it generates on your desktop to support@plugable.com? Here’s how:
http://plugable.com/support/tools/dis…

Thanks for your patience! We’ll get this figured out.
Bernei


#3

First off, thanks for the quick reply!

I did install the newest drivers. When first plugging in the device, it gives the audible tone for recognition, but then when I check USB devices in device manager, it has a a exclamation in xHCL with a code 43 error. Then when I try to run the system compatibility check with the support tool, it says there is no device attached to the computer.


#4

Hi John - Thanks for the quick reply. Would you be able to post two things here:

  1. a screenshot of the problem in device manager (using Windows’ built-in “snipping tool”
  2. The contents of the system_details.txt file that the DisplayLink support tool should have placed in the most recent subdirectory of the “DisplayLink Support Files” directory on your desktop?

That’ll let us know more about the error and what USB 3.0 host controller hardware and driver you have installed.

Thanks!
Bernie


#5

Bernie: I sent two separate emails with the screenshot and the systems_details.txt file you requested. Hoping you find a solution so I can use my dock. Thanks,


#6

Hi John – Sorry, I didn’t get them yet. Can you confirm if you emailed them to support@plugable.com ? If they go there, they’ll get routed to me. Thanks!


#7

Just an update for everyone else – we’re seeing several cases where the UD-3000 or other USB 3.0 devices won’t work because of an xHCI error.

This problem will manifest itself as a Code 43 on the Intel xCHI root port, like this screen shot:

!](https://d37wxxhohlp07s.cloudfront.net/s3_images/822268/win8-intel-xhci-code43_inline.PNG?1353719196)](https://d37wxxhohlp07s.cloudfront.net/s3_images/822268/win8-intel-xhci-code43.PNG?1353719196)

So far, our theory is this is a problem with Microsoft’s drivers, perhaps introduced with one of the post-Win8 updates (e.g. http://support.microsoft.com/kb/2756872).

There is quite a bit of discussion of it on the web:
http://communities.intel.com/thread/3…
http://www.win8heads.com/windows-8-up…

But we’re not at all certain yet, and are eager to hear if anyone hits any solutions or has any information which conflicts with this. We don’t yet have a solution.

For anyone affected by this: Thanks for your patience while we try to figure out what’s happening with Windows 8 here.


#8

Just letting you know that I was successful in getting the HDMI-DVI adapter to load under 3.0, but still no go on dock. I took your advice and connected using a USB 2.0 cord and it installed fine. I will let you know if my office devices don’t connect.


#9

Thanks John!


#10

I too have been having issues. My USBs on my system stop working when I load the drivers for this docking station. As soon as I uninstall, all is fine. Is this a matter of simply needing to get a USB2.0 cord?


#11

Thanks for posting! If you don’t have any free USB 2.0 ports on your PC, then simply using a USB 2.0 cable (a standard A to full-sized B) will automatically make a USB 3.0 device drop into USB 2.0 mode.


#12

My computer only has 3.0 USB drives but I was able to use the 2.0 cable and I am very excited to say that things seem to be working just fine now. Thank you for your help!


#13

Bernie has posted a driver fix for the 3.0 issue here. http://plugable.com/2012/12/01/window…

This worked very well for me. I followed the directions very carefully and it all worked beautifully. Now my 3.0 is working with all my peripherals (LAN, Multiple Screens, 3.0 transfer speeds).

Only thing I had to do differently was access the “Disable driver signature enforcement” a different way than the current instructions. To help my fellow users, this is what I did:
Select Charm Bar>Settings>Change PC Settings (at the very bottom of the window)>General (left side PC settings)>Advance Startup (last section-you will need to scroll)>Restart now>Troubleshoot>Advanced Options>Startup Settings>Restart (not “reset” as in the other directions)>Select Option 7= “Disable driver signature enforcement”.

This will allow you to install both drivers as per the directions.


#14

Hi John - Thanks so much for posting the result you got with our post on replacing the Microsoft stack with Intel’s – and thanks for the improvements to the steps! We’ve updated the post to reflect that.

It’s great to have you up and running finally. Please don’t hesitate to post here or email support@plugable.com if you hit any issues. The Intel stack is well proven on Windows 7, but there may be details on Windows 8 that need dealt with.

And moving forward, we expect / hope that Microsoft will release a Windows 8 fix will will eliminate the need for this switch of USB 3.0 stack.

http://plugable.com/2012/12/01/window…

Thanks again!
Bernie


#15