U3 USB 3.0 Docking Station - Window 8.1 doesn't work.


#1

I bought a new Dell computer that has USB 3.0. I bought the U3 USB 3.0 docking station about 1 1/2 weeks ago. It works fine in on a Windows 7.0 with USB 2.0.

When I attach it to my new Dell computer running Windows 8.1 the docking station shows up in device manager but drives are not recognized. I have tried multiple hard drives and they all work fine on the Windows 7.0 system. I have tried both USB 2.0 and USB 3.0 cables.

Is the docking station compatible with Windows 8.1?


#2

A little more info:

In the device manager the Docking station does show up under disk drives with no errors. In the Device Manager I can:

  1. Right click on the U3
  2. Click on Properties
  3. Click on Volume
  4. Click on populate and the actual hard drive does show up as a volume above
    the populate button.

The drive is not available as a drive letter


#3

Hi Bill,

Thanks for your post and the additional info! Sorry to hear about the issues you are having, but I’ll be glad to help get to the bottom of it.

There shouldn’t be any inherent compatibility issues between the dock and 8.1. However, Microsoft have released an “Update Rollup” for 8.1 that does include some USB storage fixes, so I think installing that will be a good place to start. Link: http://www.microsoft.com/en-us/downlo…

After you have a chance to install the roll-up, can you please contact us at support@plugable.com and let us know if the behavior changes? If not, we’ll then proceed with further troubleshooting.

Thanks!
Gary


#4

I did some further research and found that the drive did show up in disk manager. I could assign a drive letter and it the drive worked fine. I did some further research and found that I needed to go to a command prompt and type:

diskpart
automount enable

I rebooted and drives are now recognized with a drive letter attached. Why automount was disabled I have no idea.


#5

Bill, please say more about how you assign a drive letter and add automount. Thx!


#6