TBT3-UDZ linux ethernet and usb support

I have a TBT3-UDZ that I’m connecting to a Thinkpad X1 Carbon Gen 6 running Fedora 32 linux. The dual HDMI monitor support works (although one will sometimes go black for a bit and then come back). The USB-A port and ethernet port are not recognized.

These ports work fine when connected to a Macbook Pro 16".

Do you have any suggestions for linux configuration?

Hello,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

While we do not officially support Linux it sounds like the dock may just need to be authenticated. Authentication is required for USB devices to operate (this includes the dock Ethernet, audio, and card reader).

Fedora 32 allows for Thunderbolt 3 authentication through the Thunderbolt options in the Gnome Settings (https://fedoramagazine.org/thunderbolt-how-to-use-keyboard-during-boot-time/), non-gnome computers can use bolt/boltd/boltctl commands via the terminal to authenticate.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer | Product Owner
Plugable Technologies

Thanks, Joshua. I tried rebooting with the dock connected, and when it came up it recognized the ethernet. I also tried rebooting while disconnected after that, and reconnecting later, and things worked.

So I think maybe the boot while connected step may have gotten things properly connected and configured.

1 Like

Thanks for letting me know! Glad that it seems to be working as expected now. If you run into further issues just let me know, always happy to try and help!