superspeed usb 3.0 docking station windows 8


#1

I’m trying to get this to work for the first time. I’m using a Toshiba laptop and windows 8. I’ve downloaded the latest drivers and installed, everything is plugged in but I can’t get it to work with my monitor.


#2

Also since I installed the drivers my mouse usb mouse won’t work. Is that a common thing or fluke?


#3

Thanks for posting! Sorry for the frustration! We’ll be able to help.

If, when you open Windows 8’s “Device Manager” you see a yellow exclamation on the “Intel xHCI Host Controller Root Hub” (with error “code 43”), you’ve hit a new conflict with Windows 8.

It causes all USB 3.0 ports to stop working when the dock is plugged in – but USB 2.0 ports will continue to work fine, and rebooting Windows eliminates the errors on the USB 3.0 ports.

If that’s it, there are several solutions, including replacing the Microsoft USB 3.0 stack with Intel’s:
http://plugable.com/2012/12/01/window…

But we’d rather go the route of getting the firmware on your UD-3000 updated, which also solves the issue. If you have access to a Windows 7 machine with USB 3.0, you can apply that upgrade yourself by plugging in the UD-3000 and running:
http://plugable.s3.amazonaws.com/bin/…

Then move the UD-3000 back to the Windows 8 machine (reboot if USB 3.0 ports had previously stopped working). All should be well.

If not, or if you don’t have access to a Windows 7 USB 3.0 machine, it’s no problem. Just email support@plugable.com with your Amazon order number, and we’ll be able to get you up and running.

Thanks again for posting and thanks for your patience!
Bernie


#4