Slow frame rate on computer

Hello,

Whilst using the plugable for two externals screens from my laptop, the frame rate seems to be slow (e.g. when minimising / maximising a programme).

Is there a quick fix for this?

Thank you,

Jack

Hi Jack,

Thank you for posting!

The behavior you describe when using the UD-3900 docking station for Windows is not expected, so our next step is to get some additional information.

If you would, please keep the dock connected to your system and both external displays connected to the dock (even if not working as expected) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 296496’ in the subject line.

This will allow us to match things up as well as enable us to examine some log files from your system to help determine the next steps.

** Please also include the Amazon Order ID number for the UD-3900 purchase in your direct email **

*** Please do not post the Amazon Order ID number or the PlugDebug file in our public forum ***

Thank you for giving us the chance to help!

Bob
Plugable Technologies

For the benefit of anyone else following this thread, Jack has reported that the problem is now resolved.

In this specific case, the solution was to ensure that the dock was connected to a USB 3.0 port within the laptop (as opposed to a slower USB 2.0 port) as well as perform an install of an updated DisplayLink driver version.

It is important to note that each specific support case is different, and the solution here may not apply to all similar cases.

Should any of our other customers run into any similar problems, the best practice is to reach out to us directly via support@plugable.com with the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug and their Amazon Order ID number so that we can determine the next steps.

Thank you,

Bob