Screen blank after latest update


#1

I have been using the UD-3900 with my Surface 3 for months with no issues. Today after an update (Plugable update) the screen is now blank.

The PC see’s it and acts like its there but the screen is blank.

I tried uninstalling the update but it didn’t help.

How do I fix this?

This is the same problem as posted here: http://gsfn.us/t/4nq5u

A solution was posted (below) and then the topic was closed before verifying the solution worked, that’s good support right there.
The solution provided didn’t work for me, my second monitor is now not even detected, I followed the steps exactly 6 different times, I tried it with 7.7M0 as recommended and 7.7M2 and 7.6M2, none of them worked.

"Thanks for contacting Plugable! I’ll be glad to assist.

We’ll want to proceed with a clean installation of the DisplayLink drivers, just in case the previous uninstallation left some items behind. We’ll do all of the following with the dock power and USB disconnected, until the very last step.

-Disconnect the dock from the computer

-Uninstall DisplayLink Core software from Control Panel->Programs

-Download and run the DisplayLink cleaner tool, found here:
http://displaylink.com/techsupport_fi

-Once the Cleaner has been run, reboot (even if not prompted to)

-Now download and run the DisplayLink 7.7M0 software, found here:
http://www.displaylink.com/support/sl

-Reboot, even if not prompted to

-Once you’re back in Windows, reattach power to the dock, followed by USB and let it install and update the firmware which should happen automatically.

If this doesn’t resolve the behavior, please email support@plugable.com with “Ticket 76194” in the subject line and we can proceed from there.

Thanks!
Gary"


#2

Hi Shane,

Thanks for reaching out to us, I’d be more than happy to assist you with your Plugable UD-3900 docking station.

We’ve encountered this issue a couple times in the past, we’re still trying to isolate the exact update that is causing the problem. We’ve had luck resolving this problem by updating to the latest Intel drivers.

First, can you please download the latest driver found here:
http://downloadcenter.intel.com/confi…

Next, you’ll want to extract the drivers to a folder of your choosing. Please note that the drivers *won’t* install from the Setup.exe.

We’ll want to install the drivers manually. Please go to the Device Manager -> Display Adapters -> Intel HD Graphics Family -> Driver Tab -> Update Driver -> Browse my computer for driver software -> Let me pick from a list of device drivers on my computer -> Have disk -> Browse (Then browse to the folder where you extracted the download above, followed by the “Graphics” sub-folder) -> Click to highlight the file titled “kit64ics.inf” and then click “Open”, followed by “OK” and “Next”.

The screen will probably flash a few times, and after a few moments you should see a message saying “Windows has successfully updated your driver software”. After the driver has installed, please make sure to reboot even if not prompted to do so.

Does this help at all?

Regards,

Stephen
Plugable Technologies


#3

After following the steps provided by Gary Zeller it’s not working at all now. It used to detect the display and be able to control it just not display anything, now it doesn’t detect display at all.
I tried installing the DisplayLink driver again after re-installing the driver following the steps you provided.

Display Link Steps Followed:
-Disconnect Plugable dock
-Remove DisplayLink Core Eoftware (and DisplayLink Graphics)
-Reboot
-Run ‘Cleaner tool’
-Reboot
-Install DisplayLink 7.7M0
-Reboot
-Plug in dock to computer
Nothing happens …


#4

Without any other steps I installed 7.7M2 as a “What’s the worst that could happen?” and it seems to be working now.

Not sure if the Intel driver thing helped or if it was repeated re-installation it just finally felt like working.


#5

Hi Shane,

Glad to hear that things are back into a working state.

Please let us know if you run into any other problems.

Regards,

Stephen
Plugable Technologies


#6