scanner problems with ud-3900


#1

I replaced my Plugable usb2 10 port hub with the ud-3900. My Canon mf4450 printer worked fine for printing and scanning. On the 3900 printing works fine but I can no longer scan. I have to pull the connector and plug into the laptop directly and scanner function is restored. Help, I would to avoid this work around. Thanks. I live in Seattle so enjoy using a local product. Laptop is on Windows 10. When I tried to edeposit the web page gave a trying to connect message so it appears to see a scanner…


#2

This is a stab in the dark, but is the USB cable connecting the printer/scanner to the docking station longer than 6 feet? If so, please test the scanner with a shorter USB cable to see if this makes a difference.


#3

I had the “too long cable” problem previously before using the ud-3900 so now I’m using a three foot cable. I did re-power everything and reconnected the printer so when I retried the Canon ToolBox.to scan, it recognized the printer right away and did the scan. Hopefully this continues to work…


#4

OK, sounds like a plan. You can also reach us at support@plugable.com.


#5