PSS-SDC1 USB device not recognized


#1

Hi,
I have a had problems with getting a new PSS-SDC1 drive dock to connect to my windows 8 machine. It is a Dell Latitude E6220 running windows 8 (not 8.1). I also have a USB3-SATA-U3 drive dock that has worked fine with the same drives.

When I plug the device in and power it on, windows repeatedly tells me that the “USB device not recognized”.!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1054387/plugableerror_inline.jpg?1399594952)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1054387/plugableerror.jpg?1399594952)

As a test i have a brand new machine that was recently built, I loaded up a bootable image onto a drive, and used the USB3-SATA-U3 to boot to it fine, i tried the same experiment with the PSS-SDC1 dock and there was no luck booting.

Any help would be appreciated!
Thanks!
Mike


#2

Hello Mike,

Thank you for contacting Plugable support! I’d be more than happy to assist you with this issue.

I suspect there may be an issue with your PSS dock, potentially just the USB 3.0 cable. Can you try the USB cable from your U3 with the PSS and see if the PSS works?

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Plugable Technologies


#3