Plugable USB-BT4LE USB Bluetooth 4.0 - Apple Trackpad not recognised?


#1

Hi

The Apple wireless Bluetooth keyboard is identified immediately, but sadly the Apple wireless trackpad does not get discovered

I have installed the latest Bluetooth driver software twice, but same result ! no error messages, all software enabled and working normally … HID drivers were also auto downloaded

Using Windows 7 on an acer laptop, with no problems running Linux and Chrome.

Although the Apple wireless keyboard is found, it does not work … it would be useful to know if this adapter worked with the Apple products

Many thanks in advance

Glyn


#2

Hi Glyn,

Thank you for posting your question about the Bluetooth adapter and your trackpad. I’m sorry you haven’t been able to pair it yet.

Can you tell me the model of the trackpad you are using?

The Bluetooth adapter works with any device that follows the standard Bluetooth protocols, and we have successfully used it with Apple Bluetooth keyboards. We haven’t tested it with an Apple Trackpad yet, but if it is standard Bluetooth, we should be able to get it working.

Have you been able to pair the Bluetooth adapter with any other device, for example a cellphone?

Also, many devices won’t pair with a second device if they are already paired with a current device. For example, if a keyboard were paired with one computer, that pairing would have to be erased, or Bluetooth turned off on that computer, before pairing the keyboard with another.

Thank you,

David
Plugable Support


#3

Hi David

The Apple models are brand new;

http://www.apple.com/uk/keyboard/
http://www.apple.com/uk/magictrackpad/

Which from what you have said should work …

I de-installed the drivers and reinstalled, and as you suggested, prior to sending you this inquiry, I also tried to pair only one device with one computer at a time, each time the keyboard would be discovered and paired successfully, but would not function, while the trackpad would both not be discovered or function (using fully charged batteries)

I will try a cellphone to see if I can get a successful pairing, I have already discovered and paired successfully with the above apple keyboard, which then does not function, while the trackpad is non functioning …

Maybe I have a faulty unit?

Thank you for your swift response

Glyn.


#4

Hi Glyn,

It’s possible the adapter is malfunctioning, in which case we will replace it right away.

However, if it is seeing and pairing with the keyboard, there is communication going on, so the adapter is probably working, and it is more likely we are seeing a software issue, possibly a driver.

I would like to ask you to do a few things that will help troubleshoot.

  1. Could you see if the keyboard and trackpad can connect with another Bluetooth device (such as a phone or tablet)? Be sure to unpair them before trying to pair again with the computer.

  2. Try to pair the Bluetooth adapter with a cellphone or other Bluetooth device.

  3. We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the adapter into your computer, pair as far as possible with each device, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please send the resulting file to us directly at support@plugable.com, and put “For Ticket #40590

Thank you,

David
Pluguble Support


#5

Hi David

Many thanks for your reply and helpful testing schedule which I would have followed, but I have decided on this occasion to use a different adapter which is known to function with both the Apple wireless Keyboard and Trackpad with Windows 7. I already own a number of plugable products which are excellent with excellent customer support which you have demonstrated. My first call for adapters is always plugable and I thank you once again for your assistance.

Best regards

Glyn


#6

Hi Glyn,

Thank you for the update. I’m sorry we couldn’t help you more.

If you don’t anticipate another use for the adapter, please don’t hesitate to return it under Amazon’s 30-day return policy. We don’t want you stuck with a product you don’t need.

David
Plubable Support


#7

Hi David

Many thanks for your help, it’s not a straight forward process but both Apple keyboard and magic trackpad are now working perfectly.

Thanks again

Glyn.


#8

Wonderful! I’m glad to hear it worked for you.

David


#9