Plugable USB 3.0 screen not displaying at all


#1

I’ve been using Plugable USB 3.0 for just about a year, running HP laptop with Windows 10 Enterprise and Dell dual screen monitors. It’s been working fine up until recently. Now I get no display at all. Everything else seems to be working fine, and I get a ping with I plug and unplug into all USB ports of my lap top, but the screens no longer project. I’ve tried reinstalling the latest drivers but no luck. Can you help


#2

Thanks for contacting us!

This could be any number of things, but first we’ll want to make sure that your DisplayLink drivers are installed properly and are up-to-date. We’ll want to proceed with a clean installation of the drivers, and see if the behavior is any different. We’ll do all of the following with the dock disconnected, until the very last step.

-Disconnect the dock from the computer
-Uninstall DisplayLink Core software from Control Panel->Programs. Don’t worry if this fails, just move onto the next step.
-Download and run the DisplayLink cleaner tool, found here:

http://www.displaylink.com/downloads/…

-Once the Cleaner has been run, reboot (even if not prompted to)
-Now download and run the latest DisplayLink software, found here:

http://plugable.com/drivers/displaylink/

-Reboot, even if not prompted to
-Once you’re back in Windows, reattach the dock and let it install and update the firmware which should happen automatically.

Let me know if that helps! If not, please contact me at support@plugable.com so I can gather some logs and investigate.


#3

Sam: thanks for the prompt, and accurate response. This worked! Now that’s customer service!


#4

Glad to hear that worked!

If you continue to experience any issues, please do contact us at support@plugable.com for the quickest service.


#5